This is a static archive of our old Q&A Site. Please post any new questions and answers at

Wireshark on osx 10.5 prompts to install X11 for osx 10.3 even though X11 already installed


I just downloaded the latest wireshark for osx.

When I try to launch it, I get a message "Failed to start X11. requires Apples X11, which is freely downloadable from Apples website for Panther (10.3.x) and available as an optional install from the installation DVD for Tiger (10.4.x) users."

Then there is a button "get X11 for Panther".

I'm not using 10.3, I'm on 10.5. I also have X11 installed and use it regularly for other applications.

What is the problem?

asked 24 Nov '10, 12:14

bea's gravatar image

accept rate: 0%

edited 24 Nov '10, 12:19

One Answer:


I'm on OSX Snow Leopard (10.6.7) and had the same problem. Upgrading to the latest XQuartz release didn't help. I solved it by doing the following:

  • Replacing the PATH entry in my ~/.MacOSX/environment.plist file with an export PATH= statment in ~/.profile.
  • Uninstalling XQuartz.
  • Re-installing X11 from the Snow Leopard install disk's Optional Installs.
  • Installing the latest OSX 10.6.7 Update Combo available on the Apple downloads site. (Merely running Software Update from the Apple menu was not enough.) This solved a png library issue that prevented Wireshark from running even after the X11 error was fixed.
  • Re-installing Wireshark.

I'm sure I logged out and restarted in between some of those steps.

answered 14 Apr '11, 15:36

foresto's gravatar image

accept rate: 0%

edited 14 Apr '11, 15:38