This is a static archive of our old Q&A Site. Please post any new questions and answers at

Couldn’t load module….specified module cannot be found.


I downloaded and installed Wireshark 1.8.0 executable (win32). Its runs without a problem.

I have a custom dissector that I have been using since at least Wireshark 1.4.x. I downloaded the 1.8.0 source and compiled it and my dissector. I ran Wireshark out of the gtk2 subdirectory; and it ran great, and my dissector had no issues.

I copied my dissector (adsb.dll) to C:\Program Files\Wireshark\plugins\1.8.0\, where my downloaded Wireshark resides. Then, I ran Wireshark and got an error box, telling me:

Couldn't load module C:\Program Files\Wireshark\plugins\1.8.0\adsb.dll: 'C:\Program Files\Wireshark\plugins\1.8.0\adsb.dll': The specified module could not be found

Puzzled, I took my adsb.dll that was compiled against Wireshark 1.6.5 and put that in the 1.8.0 directory. That too has the same error message. Being that I've used this dissector with no errors as recently as 2 days ago and that the source hasn't been modified since January, I have to believe Wireshark 1.8.0 is behaving differently.

Once again, the dissector and Wireshark run fine out of the gtk2 subdirectory, but once I move the plugin into stock Wireshark 1.8.0, it cannot load the module without giving me a vague error.

Any help is certainly appreciated.

asked 25 Jun '12, 11:29

Mike_P's gravatar image

accept rate: 0%

edited 25 Jun '12, 19:43

helloworld's gravatar image


One Answer:


The message can be generated due to several reasons. Can you please check:


compiler version. What did you use?[email protected]/msg08764.html

vc++ redistributable

If that does not help, please file a bug report on and attach the plugin DLL.


answered 26 Jun '12, 02:14

Kurt%20Knochner's gravatar image

Kurt Knochner ♦
accept rate: 15%

edited 26 Jun '12, 02:17

Thanks for the feedback.

I decided to kind of go that route. I was running Visual C++ 2008 Express. I bumped up to 2010 Express to try to see if that helped. It took a bit of wrangling to get it working since Windows did not like having different versions of things with service packs applied on my XP box. But that indeed solved the problem once I went to 2010 Express.

My Win 7 x64 box was a different matter. I had to completely uninstall 2008 Express and any traces of the redistributable and only then could I remove the Win7 SDK 7 so I could upgrade to 7.1 and SP1. After I got that done, I could upgrade to C++ 2010 Express.

Which I forgot does not natively support x64 compiling. Regardless, I got that working, too. In the end, upgrading to Visual C++ 2010 Express on my x86 and x64 boxes solved my problem of compiling my dissector and using it with the stock 1.8.0 version of Wireshark.

(26 Jun '12, 13:28) Mike_P

Wireshark 1.8.0:

Built using Microsoft Visual C++ 10.0 build 40219

Wireshark 1.6.8:

Built using Microsoft Visual C++ 9.0 build 21022

That should explain your problems.

(28 Jun '12, 01:51) Kurt Knochner ♦