This is a static archive of our old Q&A Site. Please post any new questions and answers at

Wireshark windows build not working due to ZLIB



"The windows builds might be working at buildbot (buildbot Windows-XP-x8)."

New developers are stopped at first point (compilation ) we are not able to download the file required for compilation. ("same case for 64 Bit" ).

The wget works but while unzipping it fails, Its not a problem with Zip utility (tried all util's on the planet 7zip,winrar,winzip... ) non worked.

some body has messed up with the zlib kept in the trunk.

I struggled a lot to get the proper and compiled it.

Please fix it .

Build bot will not face problem because after "nmake -f Makefile.nmake setup" the script will not download using wget if the is present in "c:\wireshark-win32-libs" directory.

I tried very hard for about a week to find a proper zlib.

Regards Harsha K Gowda

asked 23 Aug '12, 03:58

Harsha's gravatar image

accept rate: 0%

edited 23 Aug '12, 04:42

grahamb's gravatar image

grahamb ♦

Try downloading the file from below link you will face the same problem.

(23 Aug '12, 04:09) Harsha

One Answer:


Works for me, using your link I'm able to download and open the zip file using 7-zip and Windows Explorer (on XP).

I've also just built on XP, deleting so ensuring setup downloaded it again with no issues.

answered 23 Aug '12, 04:42

grahamb's gravatar image

grahamb ♦
accept rate: 22%

Thanks for checking . For some strange reason my firewall is blocking it. :)

(23 Aug '12, 06:47) Harsha