This is a static archive of our old Q&A Site. Please post any new questions and answers at

msvcr80.dll error trying to start tshark on windows server 2003


I tried win32 1.4.1 and 1.2.12 installers from

When I try to start tshark I get an error about msvcr80.dll. Notes;

  • the installer puts msvcr90.dll in the Wireshark directory.
  • Is tshark built in some way that is wrong for MS server 2003? it works OK on XP.

I tried to use wireshark instead of tshark, as a workaround. It has similar options. however, I could not figure out how to use it in a script, as I had to press a key to get the DOS window to exit.

[edit] I have filed a bug report too.

To use wireshark, as a workaround for tshark not working, it looks like

wireshark -i 2 -p -a duration:10 -k -Q -w - -z io,stat,10,ip.addr==snip >> %logfile% 2>&1

should work. However, this gives major pain. The log file indicates that it is invoking tshark, which then grumbles about -k and -w not being allowed. A stack trace interspersed with strange characters follows.

asked 21 Dec '10, 03:48

andy%20buckle's gravatar image

andy buckle
accept rate: 0%

edited 21 Dec '10, 04:43