This is a static archive of our old Q&A Site. Please post any new questions and answers at

X11 hang when cycling through windows on Mac 10.6.5 with Wireshark 1.4.0 and 1.4.2


I just downloaded the snow leopard 64 bit version of wireshark 1.4.2. The same problem with my 1.4.0 version. With the wireshark window open (in X11), if I hit the tilde key (~) to cycle through the windows, it cycles once but then freezes and wireshark will not do anything at all. I have to quit X11 and start back over. I've not noticed this before. I've used wireshark for a couple of years now. It may be some recent change in my environment.

If there is some why I can help debug this, please let me know.

Thank you, pedz

asked 31 Dec '10, 08:32

pedz's gravatar image

accept rate: 0%

edited 01 Jan '11, 13:15

Guy%20Harris's gravatar image

Guy Harris ♦♦

2 Answers:


I'm not aware of any functionality to cycle through X11 windows (on OS/X) by pressing the tilde-key. If this a personal setting or shortcut, what key-sequence does it represent?

(the tilde-key is also not a Wireshark assigned key to cycle through it's open windows)

answered 01 Jan '11, 01:51

SYN-bit's gravatar image

SYN-bit ♦♦
accept rate: 20%

Oops, I should have googled first and then answered :-)

Apperently the Command+` does indeed cycle through the open X11 windows. I just tried it myself on my Mac and it does cycle through all windows, not freezing on the Wireshark ones. I'm using a development version, but also tried with version 1.4.0.

It must be something in your environment. What have you tried so far to isolate the issue?

(01 Jan '11, 01:58) SYN-bit ♦♦

I just discovered that this is a Mac problem. I can recreate it using pure Mac xterms. It is really horrible. Once it freezes, the whole X11 system is frozen.

I found this discussion: (in case someone else bumps into this thread in their searches)

(I don't use the X11 stuff much and should have tested more before posting. Sorry)

(01 Jan '11, 06:43) pedz


What version of OS X do you have?

To trigger this bug, you need a non-default setting for quartz-wm, "The problem only occurs for me if the "Enable key equivalents under X11" option is disabled from the System Preferences/Input tab." :

So just run Software Update and you should be fine.

answered 02 Jan '11, 00:41

jeremyhu's gravatar image

accept rate: 0%

I.e., this bug should be fixed in 10.6.5; were you running 10.6.5, or an earlier release? If it's an earlier release of Snow Leopard, Software Update will update you to 10.6.5.

Get the OS version from "About This Mac..." in the Apple menu. Also, get the version of X11 from "About X11..." in the X11 menu when X11 is in the foreground; on my 10.6.5 machine, the version is "XQuartz 2.3.6 (xorg-server 1.4.2-apple56)". If that's not the version you have on a 10.6.5 machine, that might be the problem.

(02 Jan '11, 15:57) Guy Harris ♦♦

Hmmm... I'm running 10.6.8 with XQuartz 2.3.6 (xorg-server 1.4.2-apple56) and "Software Update..." says that my software is up-to-date. Still, I do now also get the same freezing behavior when cycling through X11 windows with "CMD+`".

Enabling the "Enable key equivalents under X11" option does indeed make the problem go away.

(27 Nov '12, 09:16) SYN-bit ♦♦