This is a static archive of our old Q&A Site. Please post any new questions and answers at

Lua code broke after update to wireshark 1.8.3


This code worked fine on wireshark 1.4.4 but crashes wireshark after update to 1.8.3.

  1. How to fix it?
  2. Why the heck wireshark compelety crashes? Doesn't it walidate calls from lua wrapper? It should be too "thin" wrapper.

asked 15 Nov '12, 11:49

xpeh's gravatar image

accept rate: 0%


Nice comment you made on the issue you linked to.

Wireshark is GPL and the source is freely available for modification and improvement by anyone. Patches for the issue would be gratefully accepted.

(15 Nov '12, 12:43) grahamb ♦

GPL is neiter a quality sign nor an attibute of open development. But if you invented it, you may grow beart, stomach and eat dirt from feet.

Breaking API is bad. Crashing because of function call is bad too. I don't know how it's in C, but in high-level languages it have to be avoided.

(15 Nov '12, 12:59) xpeh

grahamb, you are funny. I don't want to patch an issue which [b]wireshark[/b] caused without any good reason, [b]wireshark team[/b] has to patch it. It's their fault, not ours. Our plugin worked.

(16 Nov '12, 13:33) xpeh

One Answer:


Looks like you also opened a bug 7976 for this. Suggest sending followups there.

answered 15 Nov '12, 14:56

JeffMorriss's gravatar image

JeffMorriss ♦
accept rate: 27%