This is a static archive of our old Q&A Site. Please post any new questions and answers at

Compiling problem installing a dissector plugin to wireshark



I need to add an available dissector plugin (called IPMB) to wireshark.

In order to do it I'm following the README.plugin procedure. Since the plugin source files are given, I just make the suggested modifications to the, Cmaketlist.txt etc... Then, from the wireshark source directory I execute:

./ ./configure make

The compiling process correctly starts but after a while I get this error concerning the new plugin directory:

make[3]: Leaving directory /home/userme/wireshark-1.8.3/plugins/gryphon' Making all in ipmb make[3]: Entering directory/home/userme/wireshark-1.8.3/plugins/ipmb' make[3]: No rule to make target all'. Stop. make[3]: Leaving directory/home/userme/wireshark-1.8.3/plugins/ipmb' make[2]: [all-recursive] Error 1 make[2]: Leaving directory /home/userme/wireshark-1.8.3/plugins' make[1]: [all-recursive] Error 1 make[1]: Leaving directory/home/userme/wireshark-1.8.3' make: [all] Error 2

I'm using: -Ubuntu 10.04 LTS (2.6.32-45-generic)

-wireshark 1.8.3

-Python 2.6.5

-Perl, v5.10.1

-GNU sed version 4.2.1

-flex 2.5.35

-bison (GNU Bison) 2.4.1

-autoconf 2.13

-automake 1.9.6

Am I missing something? I hope that someone will help me to found a solution..

Thank you very much.

asked 18 Nov '12, 07:30

matte87's gravatar image

accept rate: 0%

I just make the suggested modifications to the, Cmaketlist.txt etc...

can you please post the modifications you made?

(18 Nov '12, 13:05) Kurt Knochner ♦

Thank you for your reply,

Here the modifications I done:

3.2.1 Changes to plugins/

-include Custom.make SUBDIRS = $(CUSTOM_SUBDIRS) \

asn1 \
docsis \
ethercat \
giop \
gryphon \
interlink \
ipmb \
irda \
m2m \
mate \
opcua \
profinet \
sercosiii \
stats_tree \
unistim \
wimax \

3.2.2 Changes to plugins/Makefile.nmake


asn1        \
docsis      \
ethercat    \
giop        \
gryphon     \
interlink   \
ipmb        \
irda        \
m2m         \
mate        \
opcua       \
profinet    \
sercosiii   \
stats_tree  \
unistim     \
wimax       \

3.2.3 Changes to the top level

plugin_ldadd = $(CUSTOM_plugin_ldadd) \

-dlopen plugins/asn1/ \
-dlopen plugins/docsis/ \
-dlopen plugins/ethercat/ \
-dlopen plugins/giop/ \
-dlopen plugins/giop/ \
-dlopen plugins/gryphon/ \
-dlopen plugins/interlink/ \
-dlopen plugins/ipmb/ \
-dlopen plugins/irda/ \
-dlopen plugins/m2m/ \
-dlopen plugins/mate/ \
-dlopen plugins/opcua/ \
-dlopen plugins/profinet/ \
-dlopen plugins/sercosiii/ \
-dlopen plugins/stats_tree/ \
-dlopen plugins/unistim/ \
-dlopen plugins/wimax/

3.2.4 Changes to the top level

AC_OUTPUT( .... plugins/gryphon/Makefile

plugins/interlink/Makefile plugins/ipmb/Makefile plugins/irda/Makefile plugins/m2m/Makefile plugins/mate/Makefile ....)

3.2.5 Changes to epan/

-include ../plugins/Custom.make plugin_src = \ ....

../plugins/giop/packet-coseventcomm.c \
../plugins/gryphon/packet-gryphon.c \
../plugins/interlink/packet-interlink.c \
../plugins/ipmb/packet-ipmb.c \
../plugins/irda/packet-irda.c \
../plugins/m2m/packet-m2m.c \
../plugins/m2m/wimax_tlv.c \
../plugins/mgcp/packet-mgcp.c \
../plugins/rdm/packet-rdm.c \

3.2.6 Changes to CMakeLists.txt



I didn't complete the section 3.2.7 (README.plugin) since it seems to be just for the windows installation...


(18 Nov '12, 15:10) matte87

O.K. and how do your make files in the directory ./plugins/ipmb look like? Did you apply all required changes there as well? I guess no, otherwise there would be no error message.

(18 Nov '12, 15:59) Kurt Knochner ♦

You are quoting from the Wireshark 1.6 tree. Wireshark 1.8 has no interlink plugin.

(18 Nov '12, 23:03) Jaap ♦

Hello Jaap,

you're right, since I tried also with the version 1.6 I quoted from this by mistake..Anyway, for both versions I get the same error..Can it be something related to the environment?

I used the files ( within the plugin, I will try to repeate one more time the procedure.

Thank you

(18 Nov '12, 23:52) matte87

Hello, I solved the problem, there was an unexpected "\" next to the packet.c file into the plugin directory.

Now the building process in correctly executed but when I start Wireshark and I go to About/plugins what a I get is an empty list. I tried to create an environmental variable before the execution as suggested from the README but no plugin appear..

Have you ever face this problem?

Thank you very much

(20 Nov '12, 10:43) matte87

If you run Wireshark from the build directory, don't run it as root and you will (most certainly) see the plugins.

(20 Nov '12, 10:50) Kurt Knochner ♦

Running Wireshark not as root I get the this error:

OOPS: dissector table "sctp.ppi" doesn't exist Protocol being registered is "Datagram Transport Layer Security" 19:56:44 Err Field 'OEM IANA' (ipmb.session.oem.iana) is an FT_BYTES but is being displayed as BASE_HEX instead of BASE_NONE


(20 Nov '12, 11:01) matte87

Did you already try this (as non-root):


(20 Nov '12, 11:19) Kurt Knochner ♦

Err Field 'OEM IANA' (ipmb.session.oem.iana) is an FT_BYTES but is being displayed as BASE_HEX instead of BASE_NONE

wait a moment. That looks like a "bug/problem" in the code, doesn't it?

Where did you get the IPMB plugin source code from?

(20 Nov '12, 11:20) Kurt Knochner ♦

Hello kurt,

exactly, it comes from the plugin code. Since I'm not the plugin author I don't know really what it means. Can it be some conflict with some wireshark definitions? i will try to look into..

(20 Nov '12, 11:40) matte87

Is that code publicly available? If so, please post the link.

(20 Nov '12, 11:44) Kurt Knochner ♦
(20 Nov '12, 11:47) matte87

The error seems to come from this part of code:

  { &hf_ipmb_oem_iana,{
 "OEM IANA", "ipmb.session.oem.iana",


 &quot;ipmb OEM IANA&quot;, HFILL }},</code></pre><p>I changed the display type from BASE_HEX to BASE_NONE and I get a new error:</p><p>21:53:40 Err register_subtree_array: subtree item type (ett_...) not -1 ! This is a development error: Either the subtree item type has already been assigned or was not initialized to -1. Aborted</p></div><div id="comment-16132-info" class="comment-info"><span class="comment-age">(20 Nov '12, 13:01)</span> <span class="comment-user userinfo">matte87</span></div></div><span id="16133"></span><div id="comment-16133" class="comment not_top_scorer"><div id="post-16133-score" class="comment-score"></div><div class="comment-text"><p>that seems to be a patch that was never accepted.</p><blockquote><p><code></code><br />

As the code is 4.5 years old, I guess it will need some tweaking to run properly with Wireshark 1.8.3. If you don't know how to do that yourself, it's probably best to contact the original author/maintainer of the code and ask if he/she has got a new version or if he/she is willing to help. Contact details are available in the AUTHORS file and in the a bug comment.

If you need this for business purposes, someone on this site might be able to do the work for you if you pay him.

(20 Nov '12, 13:08) Kurt Knochner ♦

It is not for business purposes. I guess the only way is to start reading the documentation. Thank you all.

(20 Nov '12, 13:49) matte87
showing 5 of 16 show 11 more comments