This is a static archive of our old Q&A Site. Please post any new questions and answers at

Wireshark on Ubuntu on VMware Player


I recently installed Wireshark for Ubuntu on VMware Player. I had a problem with the interface, but that was solved when I ran Wireshark as root using sudo. I heard that was bad. How do I run it as a user with the interfaces appearing?

I also get the below error when I decide to write it to a file. Any idea how to resolve this?

Lua: Error during loading: [string "/usr/share/wireshark/init.lua"]:45: dofile has been disabled

asked 07 Jan '13, 21:02

dalawh's gravatar image

accept rate: 0%

edited 07 Jan '13, 21:02

One Answer:


See Capture Privileges wiki page for this.

The error comes from you forcing su root. This is a protective measure.

answered 07 Jan '13, 23:09

Jaap's gravatar image

Jaap ♦
accept rate: 14%

I'm looking at:

The additional privileges are provided using the Linux Capabilities system where it is available and resort to setting the set-user-id bit of the dumpcap binary as a fall-back, where the Linux Capabilities system is not present (Debian GNU/kFreeBSD, Debian GNU/Hurd).

Is there a tutorial on this?

(08 Jan '13, 07:53) dalawh

There is info on doing it manually yourself on the page Jaap linked to above. See the section headed "Setting network privileges for dumpcap".

(08 Jan '13, 08:10) grahamb ♦

@grahamb Thanks. I used "sudo setcap 'CAP_NET_RAW+eip CAP_NET_ADMIN+eip' /usr/bin/dumpcap" and everything started working.

(08 Jan '13, 08:55) dalawh

If Jaaps original answer helped (albeit with my little prompt) can you "accept" the answer (by clicking the checkmark icon next to it) for the benefit of others who may have the same issue.

(08 Jan '13, 09:54) grahamb ♦