This is a static archive of our old Q&A Site. Please post any new questions and answers at

The contents of C:\wireshark-win32-libs\current_tag.txt is (unknown)


hi all,after proper installation as mentioned in developer guide,and running this command in cmd prompt: C:\wireshark> nmake -f Makefile.nmake verify_tools,i get this error..

Microsoft (R) Program Maintenance Utility Version 10.00.40219.01
Copyright (C) Microsoft Corporation.  All rights reserved.

ERROR: The contents of C:\wireshark-win32-libs\current_tag.txt is (unknown). It should be 2013-02-19.

Checking for required applications: cl: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/cl link: /cygdrive/c/Program Files (x86)/Microsoft Visual Studio 10.0/VC/BIN/link nmake: nmake bash: /usr/bin/bash bison: /usr/bin/bison flex: /usr/bin/flex env: /usr/bin/env grep: /usr/bin/grep /usr/bin/find: /usr/bin/find perl: /usr/bin/perl C:\Python27\python.exe: /cygdrive/c/Python27/python.exe sed: /usr/bin/sed unzip: /usr/bin/unzip wget: /usr/bin/wget

p.s:i am getting the path of nmake as nmake which might be causing!!

asked 13 Mar ‘13, 01:09

ajain's gravatar image

accept rate: 0%

edited 13 Mar ‘13, 02:59

grahamb's gravatar image

grahamb ♦

i could not find the file C:\wireshark-win32-libs\current_tag.txt.i have followed all steps correctly.i could not download WS sources through svn,i just downloaded locally and put it in the c:\wireshark.what am i missing?

(13 Mar ‘13, 02:10) ajain

The path to nmake is odd. I suspect you’ve managed to create a file called nmake in the current directory. The fact that verify_tools produces good output shows that nmake is working though.

(13 Mar ‘13, 03:05) grahamb ♦

makefile.nmake and config.nmake are the only two files in c:\wireshark.what to do?getting the same error with :nmake -f Makefile.nmake setup..

(13 Mar ‘13, 04:00) ajain

If the error is simply the path to nmake I think you can ignore it. If I create a file nmake in the top level directory and verify_tools then I get the same output as you, but the build still works.

The setup step attempts to download all the 3rd party libraries using http. Are you blocked from doing that? What error do you get from the setup step?

(13 Mar ‘13, 04:18) grahamb ♦

One Answer:


Proceed to the next step "Install Libraries", because this happens on a pristine developer machine. Next time you run verify_tools it checks if your libraries are still up to date.

answered 13 Mar '13, 02:47

Jaap's gravatar image

Jaap ♦
accept rate: 14%

The "install libraries"step gives

ERROR: The contents of C:\wireshark-win32-libs\current_tag.txt is (unknown). It should be 2013-02-19.

then,it tries to connect to server( fails to connect(even using a proxy site as explained in guide fails). system may be behind company's firewall but i can go to this site through browser.can't i download the libraries directly and put them in the required directory?if yes,plz mention the links to the libraries and location to store them.also,i am working on 32bit windows xp?

(14 Mar '13, 10:10) ajain

The libraries needed are specified in Makefile.nmake and depend on the options set in config.nmake. The actual libraries themselves can be found at adjust the trunk-1.8 part for the version you are building.

All the files should be placed in your wireshark libs directory which seems to be C:\wireshark-win32-libs.

If you do this, then run setup again it will find the files and not try to download them.

(14 Mar '13, 10:55) grahamb ♦

grahamb,thanx for prompt reply..what exacty u mean by adjusting the trunk 1.8?what i'm doing is downloading those zip files and extracting to C:\wireshark-win32-libs.

(14 Mar '13, 11:40) ajain

There are different sets of libraries for each major version of Wireshark. So if your source is for 1.8.x then use the libraries in trunk-1.8, if you were building 1.6.x then you would use the libraries in trunk-1.6.

(14 Mar '13, 13:06) grahamb ♦

ok..the setup phase worked..but its looking for which i don't see in could not connect to internet,so could not move forward and extract these pkg findproc,nasm and upx301,gtk+-bundle(rest others are extracted).it ends with NMAKE : fatal error U1077: 'c:\cygwin\bin\bash.EXE' : return code '0x1'.should i move ahead with distclean and build step after extracting these manually and leaving out wiresparkle?i am working on 32 bit winxp.and rgdg version of wireshark source(i downloaded from link in step-up-step guide through tortoisesvn).

(18 Mar '13, 01:05) ajain

i assume i should be looking for building 32 bit binaries for my system(32 bit xp) but i have installed MV C++ 2010 Service Pack 1 Compiler anything brewing there?reason i am saying this because the error i was getting earlier "moonmade architecture"win32" confuse us is mentioned in config.nmake for platform setting.i am using intel xeon cpu 5160,btw?

(18 Mar '13, 01:20) ajain

If your build is looking for winsparkle then your source is for trunk. That means you need the libraries for trunk, found here:

(18 Mar '13, 03:38) grahamb ♦
showing 5 of 7 show 2 more comments