This is a static archive of our old Q&A Site. Please post any new questions and answers at

–with-pcap=directory isn’t working


I am unable to "configure Wireshark with --with-pcap=directory, ". I have my own compiled libpcap.a.

Please give some details about where i will get the configuration file. I am using ubuntu 10.10-32 bit.

Thanks in advance.

asked 19 Jul '13, 05:48

baila's gravatar image

accept rate: 0%

converted 19 Jul '13, 11:33

Guy%20Harris's gravatar image

Guy Harris ♦♦

Is your libpcap.a in the directory you specified as an argument to the --with-pcap= flag to the configure script?

What does the configure script produce as output?

Does the configure script succeed or fail? If it succeeds, at what point does the build process fail?

(19 Jul '13, 11:34) Guy Harris ♦♦

thanks Guy, i found it and works too.

thanks a lot!!

(23 Jul '13, 09:40) baila

One Answer:


The "configuration file" is the configure script in the top-level source directory.

answered 23 Jul '13, 15:49

Guy%20Harris's gravatar image

Guy Harris ♦♦
accept rate: 19%