This is a static archive of our old Q&A Site. Please post any new questions and answers at

Can`t capture EtherCAT packet



I installed Wireshark v1.4.3

When I tried to capture EtherCAT packet from my Realtek NIC, I can not see the EtherCAT packet.

I only can capture DHCP protocol packet.

Should I have to config other option to capture EtherCAT packet?

asked 16 Feb '11, 20:54

Younghyun%20Jo's gravatar image

Younghyun Jo
accept rate: 0%

edited 16 Feb '11, 23:10

Jaap's gravatar image

Jaap ♦

Hello i have a similiar problem. I cant capture ethercat messages. I am connecting to a beckhoff i/o module(EK1100) using a cross network cable. I use Twincat program for ethercat master protocol. There is no problem with the operation of the device. On same pc i use wireshark to monitor messages.

The program has two modes: run and config mode. I can capture an ethercat message which shows the switching between modes but when input and output values change i can not get a message. In twincat program i can see what has changed. I did not change anythin in wireshark and i have all the plugins, i use version 1.4.3. I could notunderstand what is going on any help will be helpful.

(31 Jan '12, 11:15) Hakan Kapson

2 Answers:


According to, EtherCAT uses either Ethertype 0x88A4 or UDP port 0x88A4. And at the link layer, it's just ethernet.So you don't have to do anything special to be able to capture EtherCAT packets. Take a look at for information on how to capture in different setups.

Regarding dissecting of the EtherCAT frame, it's done in a separate plugin, have you installed all the plugins that came with Wireshark?

answered 16 Feb '11, 22:52

SYN-bit's gravatar image

SYN-bit ♦♦
accept rate: 20%

I am sure I already installed ethercat plugin for wireshark.

I can see ethercat.dll in Wiresharkplugins1.4.3 directory.

I don`t know why this problem happened to me.

Does anyboy has another idea?

(16 Feb '11, 23:00) Younghyun Jo

(I converted your "answer" to a "comment" to adhere to the Q&A nature of this site)

Is the PC you are capturing on communicating over EtherCAT itself? If not, did you enable "promiscuous mode"? How is your capturing PC connected to the network that transfers EtherCAT messages? Did you check the CaptureSetup link I mentioned earlier?

(17 Feb '11, 00:35) SYN-bit ♦♦


Hello, i have come across the same problem. I have found the solution in the Slave Implementation Guide. The steps below are the solution.

  1. I/O Devices->your device->Adapter->set the Promiscuous Mode( use with Netmon/ Wireshark only)
  2. Scan Boxes

answered 13 Sep '13, 01:59

Ecatrui's gravatar image

accept rate: 0%