This is a static archive of our old Q&A Site. Please post any new questions and answers at

Vlan capture setup for Intel network card in windows 7


Hi guys, i'm trying to define VLAN tagging in windows7 for Intel(R) 82566DM Gigabit Network Connection. i tried the "windows xp configuration like: find out the network card brand. open registry editor (start > run > regedit or regedt32 ) find the following location: etc... but didn't work for me in windows7, so Wireshark app don't show VLAN Tagging when "Capture".

there is any different\special settings for windows7?

please advice.

asked 22 Feb '11, 07:16

mishiago's gravatar image

accept rate: 0%

edited 20 Mar '12, 21:13

cmaynard's gravatar image

cmaynard ♦♦

3 Answers:


Are you sure the traffic contains VLAN tags? On most switches you have to configure the spanport to replicate the vlan tags. Depending on the brand and model you need to specify it when configuring the spanport, configure the destination port as a vlan tagging port, etc.

answered 22 Feb '11, 08:03

SYN-bit's gravatar image

SYN-bit ♦♦
accept rate: 20%


If you are trying to capture the VLAN tags on a Cisco 802.1Q trunk port, then use this syntax:-

monitor session x source interface fa0/y

monitor session x destination interface fa0/z encpssulation dot1q

You may also need a registry edit to prevent the NIC stripping the VLAN header. I have another post ongoing on the same subject. You probably need to add a DWORD like MonitorMode or MonitoModeEnabled (I am not familar with your card, but one of these works for other Intel NICs).

Also look for a "Priority & VLAN" option in the NICs configuration (Advanced tab). Set this to "Priority & VLAN Enabled".

answered 22 Feb '11, 11:25

KeithFrench's gravatar image

accept rate: 0%

That depends on the Cisco model you're talking about... on a 65xx you need to put the destination port into trunk mode as it does not have the "... encapsulation dot1q" option when defining a spanport

(22 Feb '11, 11:33) SYN-bit ♦♦

Yes I agree & if it is running CatOS......

(22 Feb '11, 14:11) KeithFrench
(22 Feb '11, 14:20) SYN-bit ♦♦

I just meant that CatOS is totally different to IOS based 65xx cats.

(22 Feb '11, 14:28) KeithFrench

Oops... I seem to have misinterpreted the "&" :-)

(22 Feb '11, 14:30) SYN-bit ♦♦

it's seems like the configuration settings same as windows xp. i tried to define like the instruction below but unsuccessfully.

Note: In windows xp it's working excellent and obviously VLAN tagging is enabled.

please advice.

(23 Feb '11, 01:43) mishiago
showing 5 of 6 show 1 more comments


I have a different Intel NIC in my Windows 7 laptop & with the registry edits it works fine. Have you tried searching Intels KnowledgeBase?

answered 23 Feb '11, 11:20

KeithFrench's gravatar image

accept rate: 0%