This is a static archive of our old Q&A Site. Please post any new questions and answers at

Apple Maverick and X11


Hi seems that after the new Apple update Maverick. wireshark is not working. Anyone else noticing it ?, better know how to fix it ?. Error To open "wireshark-bin"you need isntall X11 Would likt ot install X11 now? 2 options 1) cancel 2) Continue -->

either via the app or command line same issue mac book pro 10.9

Wireshark 1.10.2 XQuartz 2.7.4 (xorg-server 1.13.0) Problem: X11 is not updated ( though it's the latest version)

asked 23 Oct '13, 09:02

Paisa4ever's gravatar image

accept rate: 0%

6 Answers:


I am running Mavericks and the items suggested here did not work for me. I quit Wireshark and XQuartz and reinstalled XQuartz and saw no change in behaviour. Next, I deleted the '/opt/X11' hierarchy and reinstalled XQuartz. No change. What did work was a suggestion found here:

I knew I had the latest XQuartz 2.7.5 so I launched it. In its Applications menu I added Wireshark as one of the items using the "/Applications/" path. After 12-20 seconds, Wireshark launched from that menu displayed its main window. I exited all and then double-clicked Wireshark in the Applications folder. Success. Tried a couple more times (from the Doc 'Applications', etc.) and saw success each time.

By the way, I later tried to get Wireshark running on another Mac running Mavericks. I finally got it running but wasn't sure what actions helped.

This morning I uninstalled XQuartz and Wireshark and restarted, returning to a clean state. I then re-installed XQuartz and Wireshark. Launching Wireshark nothing appeared to happen for 1 minute 24 seconds before the main window appeared. I did not have to add it to the XQuartz application list. I mention this because you have to be patient. I'm just not used to having no feedback while a background process sets itself up before displaying its application window. Be forewarned.

answered 23 Dec '13, 21:40

pjcozsyd's gravatar image

accept rate: 0%

edited 24 Dec '13, 16:05

Thank you, I thought the program froze and quit it always before a minute was up. It turns out you are right! It took a minute, thirty to start up.

(30 Dec '13, 18:13) Dygear


Ran across the same issue due to a Mac OS Mavericks update. My solution was to reinstall XQuartz (2.7.4) then relaunch Wireshark via the app. It took longer than previously to start, though within 10 seconds (MacBook Air Mid 2011) Wireshark came up. I've run it to confirm all is well.

Good luck with your situation.

answered 23 Oct '13, 10:18

SwiftAero's gravatar image

accept rate: 0%

Hi SwiftAreo

Thanks your tip works also on macbook proI did some succesful tests see below.

in opended open /opt

x11 folder visible -trashed it

Down loaded and reinstalled

Wireshark Version 1.10.0

Status : it works!

checks: open /Applications/ OK Working with saved file OK working with capturing interface OK

(23 Oct '13, 12:02) Paisa4ever

If an answer has solved your issue, please accept the answer for the benefit of other users by clicking the checkmark icon next to the answer. Please read the FAQ for more information.

(23 Oct '13, 18:08) grahamb ♦

I had the same problem with X11 not working after Mavericks install. I re-installed X11 (XQuartz 2.7.4) and that sort of worked. But now, if I start up an xterm, it comes up on the left side of my left-most monitor and is NOT movable across my screen! So, something else is broken here now, probably when then changed the multi-screen behavior.

(24 Oct '13, 21:28) Christopher ...

The problem seem to that X11Quartz does not know that on the second screen a menu bar exists. And the window decoration is hinding under the menu bar. Lets hope for a new xquartz version soon.

(25 Oct '13, 08:30) plaisthos


Well the answer for me is pretty simple. After starting X11 and Wireshark, Wiresharks asks where Quartz is. I did not found it on the list of programs, so I pressed the Browse Button on the bottom left of the program window and found Quartz in the program->Utilities Folder. I clicked on it, pressed open, and after a few seconds Wireshark started up.

Hope this helps others, now I have to understand Wireshark:-)

OS X 10.9.2 / Quartz 2.7.5 / Wireshark Version 1.10.6 (v1.10.6 from master-1.10)

answered 14 Apr '14, 01:12

Beni's gravatar image

accept rate: 0%

edited 14 Apr '14, 01:14

This is the solution. Just browse to Applications → Utilities → Quartz.

(17 Apr '14, 02:49) Mathias Bynens


You may have a ".wireshark" or a ".wireshark-etc" folder in your home folder, I deleted both and restarted wireshark. Runs fine from now on ... and nicely told me that the first startup may take a little time to build the font-cache.

answered 14 May '14, 06:26

hwde's gravatar image

accept rate: 0%

This worked for me.

(20 Jun '14, 04:10) abd3721


Christopher, an alternative is to use the 4 fingers up trick with mac, and drag your window to the other screen. I guess you're already using this trick, but I found useful to remind it for other users. :)

This answer is marked "community wiki".

answered 31 Oct '13, 02:44

amid's gravatar image

accept rate: 0%


There is a new update of XQuartz and its made for Mavericks

Good Luck :)

answered 25 Nov '13, 16:34

Sindri%20%C3%9E%C3%B3r's gravatar image

Sindri Þór
accept rate: 0%

I’m still having the issue with that version (2.7.5).

(17 Apr '14, 02:48) Mathias Bynens