This is a static archive of our old Q&A Site. Please post any new questions and answers at

Couldnt load module: undefinded symbol: dissector_add


Hi, i try to make a plugin based ASN1 dissector. I used the toyasn1 sample and only added my .asn files to the makefile of the Plugin. Now if i start wireshark i always get the error: Couldn't load module /wireshark-1.10-9/plugins/toyasn1/.libs/ /wireshark-1.10.9/plugins/toyasn1/.libs/ undefined symbol: dissector_add

The same error occours with dissector_delete.

Does someone know how to solve it?

asked 11 Sep '14, 01:54

Venturina's gravatar image

accept rate: 0%

One Answer:


The api changed to dissector_add_uint() I believe.

answered 11 Sep '14, 03:44

Anders's gravatar image

Anders ♦
accept rate: 17%

edited 11 Sep '14, 04:04

grahamb's gravatar image

grahamb ♦

Ah ok, thanks, i think you are right. But now, i get the same Error with undefined Symbol: dissector_add_unit

I don't know what that error means.

(11 Sep '14, 04:04) Venturina

_uint, not _unit

(11 Sep '14, 04:20) Jaap ♦

Aww.. thats right. Sometimes reading is difficult.

Now i geht the Error undefined symbol: dissect_TOYASN1_MESSAGE_PDU

I think this problem lies in my toyasn1.cnf right?

Because i changed the .asn input files, the dissect_TOYASN1_MESSAGE_PDU function ist not created. My .asn files are CAM.asn and ITS-Containor.asn. In an other dissector, the dissect_name_PDU is created in the packet-name-fn.c file, but in my file is no such function

thank you very much for your help!

(11 Sep '14, 05:00) Venturina
(11 Sep '14, 09:14) Pascal Quantin