This is a static archive of our old Q&A Site. Please post any new questions and answers at

Wireshark doesn’t start after upgrading to Mac OS X Yosemite


I just update my Mac OS to the Yosemite Beta 3, and the Wireshark, which used to function well, didnt work.

Every time I open wireshark, it just appear on the menu bar for a while and then quite. the user interface never shows up.

I have unistall fully wireshark and installed it agian and again, and nothing helps. Can anyone help on this issue?

asked 16 Sep '14, 09:48

Zicheng%20Wang's gravatar image

Zicheng Wang
accept rate: 0%

edited 18 Oct '14, 00:53

Guy%20Harris's gravatar image

Guy Harris ♦♦

and when i run the wireshark in the X11 terminal it shows the following error

bash-3.2$ sudo wireshark
 2014-09-16 12:53:27.554 defaults[5389:1243053] 
 The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant) does not exist
 2014-09-16 12:53:27.574 defaults[5390:1243061] 
 The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) does not exist
 dyld: Library not loaded: /usr/X11/lib/libcairo.2.dylib
  Referenced from: /Applications/
  Reason: image not found
(16 Sep '14, 09:56) Zicheng Wang

3 Answers:


linking the directories worked for me:

sudo ln -s /opt/X11 /usr/X11

answered 22 Oct '14, 09:47

Erik13's gravatar image

accept rate: 0%

Excellent solution. I works for other application as well.

(02 Nov '14, 15:24) Julio

Yes, any X11 application that's looking for X libraries/configuration files/etc. under /usr/X11 will fail after an upgrade to Yosemite, and that command will fix the problem by putting back the link that the Yosemite upgrade removed.

(02 Nov '14, 17:48) Guy Harris ♦♦

Awesome solution. Thanks bud!

(03 Nov '14, 02:23) mariansan

That worked for me.

(04 Nov '14, 14:07) RDF50

That worked for me also.

(10 Nov '14, 09:37) tc0nn

This worked like a charm. Thanks for sharing this knowledge!

(04 Dec '14, 16:10) Mechafranko

Worked for me. Thanks!

(02 Feb '15, 10:11) loseki

Worked perfect. Thank you.

(17 Apr '15, 13:35) kcb263

Thanks, I used Wireshark2 as a Workaround before

(17 Apr '15, 14:28) Christian_R
showing 5 of 9 show 4 more comments


Make sure that:

  1. /opt/X11 has X11 installed under it (for example, make sure /opt/X11/lib/libcairo.2.dylib exists);
  2. /usr/X11 is a symbolic link to /opt/X11 (ls -ld /usr/X11 should report it as such).

Installing XQuartz puts it under /opt/X11, and makes /usr/X11 a symbolic link to /opt/X11. Upgrading to Yosemite appears to destroy the /usr/X11 link; re-installing XQuartz puts the link back, which is why un-installing and re-installing XQuartz solved the problem for one of the people answering your question.

answered 16 Sep '14, 17:51

Guy%20Harris's gravatar image

Guy Harris ♦♦
accept rate: 19%

edited 18 Oct '14, 00:56

I had the same issue with the actual Yosemite rollout. I uninstalled both X11 and Wireshark from my new install. I then installed X11 and Wireshark in that order. It all works now and seems to be stable. I hope this helps for you.

(17 Oct '14, 09:38) dotnetbrett

Un-installing and re-installing X11 would probably be sufficient; the problem appears to be that upgrading to Yosemite gets rid of the /usr/X11 symbolic link to /opt/X11, and re-installing XQuartz puts the link back.

(18 Oct '14, 00:58) Guy Harris ♦♦


See the answer to this question that implies the upgrade to Yosemite "helpfully" moved X11 from /usr/X11 to opt/X11.

answered 16 Sep '14, 10:08

grahamb's gravatar image

grahamb ♦
accept rate: 22%

Actually, in Mountain Lion and later, X11 is supposed to be in /opt/X11; it's not part of the OS, it's an add-on package (from Apple, but still an add-on package). However, at least on my machine, /usr/X11 is a symlink to /opt/X11, so you should probably make sure that Xquartz is installed under /opt/X11 and that /usr/X11 is a symbolic link to /opt/X11.

(16 Sep '14, 17:49) Guy Harris ♦♦