This is a static archive of our old Q&A Site. Please post any new questions and answers at

Getting compiler error with tools/ not found


Hello, First of all my question is to how to locate source code for Wireshark release 1.10.7 with Git? My other question is I just downloaded the source code for Wireshark release 1.10.10 from the download site instead of via Git and tried to make a build as is without any modification and I am getting the following error. Not sure I am missing any. I would prefer to obtain the 1.10.7 source code via Git, but did not know how to do so, hence going this route but having issue at the moment with the build. Please suggest. thanks in advance, Muriel

        bash -o igncr tools/ "./COPYING" wireshark-gtk2
tools/ line 50: u2d: command not found
NMAKE : fatal error U1077: 'c:\cygwin\bin\bash.EXE' : return code '0x7f'

asked 02 Oct '14, 06:57

christenmu's gravatar image

accept rate: 50%

edited 02 Oct '14, 07:01

grahamb's gravatar image

grahamb ♦

One Answer:


The build error is because your Cygwin installation doesn't have the u2d command. You need to install the dos2unix Cygwin package.

1.10.7 is tagged in git, so clone the Wireshark repo (git clone and then git checkout tags/v1.10.7.

answered 02 Oct '14, 07:16

grahamb's gravatar image

grahamb ♦
accept rate: 22%

Thanks. I managed to build after reinstalled cygwin with dos2unix included. Also, I think I checked out the v1.10.7 with git checkout branch with ver specified to v1.10.7.

(02 Oct '14, 11:05) christenmu

If an answer has solved your issue, please accept the answer for the benefit of other users by clicking the checkmark icon next to the answer. Please read the FAQ for more information.

(03 Oct '14, 02:20) grahamb ♦