This is a static archive of our old Q&A Site. Please post any new questions and answers at

Trying Wireshark.exe, but “libwireshark.dll is missing from you computer”


I have been following the steps for building x32 Wireshark for Windows from source, and things had been going relatively well. I got to the "nmake -f Makefile.nmake all" step. However, it quit with an error after being unable to find a path (I no longer have this error). I went and made sure all my environment variables were correctly set, and that I had verified my tools (there was a long gap between when I last did these things and when I built.) Then, I tried to build again, and it seemed to complete successfully. There were no error messages. However, when I tried to run the Wireshark.exe file, it gave me an error message.

"The program can't start because libwireshark.dll is missing from your computer. Try reinstalling the program to fix this problem."

Which program is that, exactly? How do I fix this? I've tried building again, and I didn't have any errors in the build process.

asked 09 Jan '15, 11:52

mehubb985's gravatar image

accept rate: 0%

One Answer:


You haven't followed the instructions completely. After building you do have Wireshark.exe at the top-level of the source tree, but it can't be run from there as it won't find all the required DLL's, e.g. libwireshark.dll.

See the Dev Guide Sect 3.6.2 Run Generated Wireshark, Win32, you should cd into wireshark-gtk2 (or wireshark-qt-release for the new QT version), and run it from there, where all the DLL's have been copied to.

answered 10 Jan '15, 04:44

grahamb's gravatar image

grahamb ♦
accept rate: 22%