This is a static archive of our old Q&A Site. Please post any new questions and answers at

Openflow v1,v2 and v3 support for wireshark



I tried to build wireshark 1.12 from source by downloading tar file on ubuntu 12.0.4. After doing $sudo make install when I type $wireshark it says command not found. Then I tried $sudo apt-get install wireshark. It installed wireshark 1.11.1 version. In that I could find only OpenFlow V4 in the support protocol list.

I need to enable support for Openflow v1,v2 and v3

Please help me to fix it.

Thanks, Kokila

asked 10 Jan '15, 00:29

kokila's gravatar image

accept rate: 0%

when I type $wireshark it says command not found.

Why do you try to run $wireshark? That would be a variable ($) in your shell.

(10 Jan '15, 04:37) Kurt Knochner ♦

I have entered wireshark only. I have included $ to intimate that I am running from shell.

(11 Jan '15, 19:41) kokila

Did "make" really finsih without any errors? What happens if you go to your build directory and type ./wireshark or ./wireshark-gtk?

Openflow V1,V4 and v5 are supported by Wireshark development version. V1 support may be incomplete. I'm not sure of the status in 1.12.x

An external plugin can be found here

(12 Jan '15, 00:50) Anders ♦

wireshark.desktop and are the only files available in build directory. the output of make is given below.

make[2]: Entering directory /home/kokila/Desktop/kokila/wireshark-1.12.2/ui/qt' UIC ui_about_dialog.h /bin/bash: /usr/lib/qt4:/usr/share/qt4:: No such file or directory make[2]: *** [ui_about_dialog.h] Error 127 make[2]: Leaving directory/home/kokila/Desktop/kokila/wireshark-1.12.2/ui/qt' make[1]: [all-recursive] Error 1 make[1]: Leaving directory `/home/kokila/Desktop/kokila/wireshark-1.12.2' make: [all] Error 2

(12 Jan '15, 01:07) kokila

Seems like you don't have all the build dependencies for wireshark loaded and/or not giving the right input to ./configure.

This is what I use:

sudo apt-get build-dep wireshark sudo apt-get install qt5-default sudo apt-get install libssl-dev sudo apt-get install libgtk-3-dev

./ ./configure --with-ssl --enable-setcap-install

(12 Jan '15, 04:02) Anders ♦