This is a static archive of our old Q&A Site. Please post any new questions and answers at

Enable CANopen Protocol


Tried to log some CanOpen traffic using wireshark, but the traffic is only shown as standard "CAN" traffic. The same happens when loading the example pcap file from the wiki (

  • Tried Wireshark 1.12.3 and 1.8.2 (Stock Debian stable)
  • Can't force using "Analyze -> Decode as", this option is greyed out

Anyone an Idea how to tell wireshark to dissect the data as CANopen on top of CAN instead as "just" CAN?

Thanks for your help!

asked 15 Apr '15, 04:26

Martin%20Wagner's gravatar image

Martin Wagner
accept rate: 0%

One Answer:


Go to the protocol preferences for CAN and set the "Next level protocol" to "CANopen protocol".

answered 15 Apr '15, 04:44

grahamb's gravatar image

grahamb ♦
accept rate: 22%