This is a static archive of our old Q&A Site. Please post any new questions and answers at

1.12.4 hangs on Ubuntu after install


I dl the latest Wireshark 1.12.4 source and compiled under latest Ubuntu.
My setup:
./configure --prefix=/usr --with-gtk2=yes --with-gtk3=no --without-qt --sysconfdir=/etc --with-lua=no

The long compilation went ok (after few minor -l fixes..) and when I run the wrapping script from build dir ./wireshark, the program opens and runs OK allright.

Then, I run "make install", no errors, and I can run wireshark from path.
BUT, it hangs, forever in a loop with high CPU.
Here the strace log:
clock_gettime(CLOCK_MONOTONIC, {391, 42624826}) = 0
recvmsg(3, 0xbff3ec14, 0) = -1 EAGAIN (Resource temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {391, 43554457}) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}], 3, 23) = 0 (Timeout)
clock_gettime(CLOCK_MONOTONIC, {391, 67730651}) = 0
recvmsg(3, 0xbff3ec14, 0) = -1 EAGAIN (Resource temporarily unavailable)
clock_gettime(CLOCK_MONOTONIC, {391, 68576702}) = 0
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=5, events=POLLIN}], 3, 75) = 0 (Timeout)
clock_gettime(CLOCK_MONOTONIC, {391, 145234474}) = 0
recvmsg(3, 0xbff3ec14, 0) = -1 EAGAIN (Resource temporarily unavailable)

Any help??

asked 08 May '15, 01:44

nikita's gravatar image

accept rate: 0%

edited 08 May '15, 01:45

did you run sudo ldconfig after install? Logging off and back on might make a difference too.

(08 May '15, 03:35) Anders ♦

yes I did, it still hangs.
Can anybody explain me the meaning of those messages in the strace log?
If I could understand what those strace messages mean, I can try debug further myself the issue.

(08 May '15, 04:11) nikita

Note the OP is using Utopic (14.10) which is EOL in July 2015.

What were the "few minor -l fixes.."?

(08 May '15, 04:13) grahamb ♦

actually, I was sarcastic, I had to add lots of libs, X and common ones into configure AND makefile, it took forever to compile and make it work... but finally it worked... and, as I wrote, when I run the wrapping script from build dir (./wireshark or .libs/lt-wireshark),it works ok...
the problem I repeat, is after make install.
Any help with those strace msg?

(08 May '15, 04:40) nikita

Apparently after all your changes it doesn't work. Can you possibly try CMake instead of autotools?

Either way it might be helpful to post the configure logs somewhere for inspection. I know the problem seems to be only after install, but as your system seems to have issues configuring and building let's start there.

(08 May '15, 04:47) grahamb ♦

On another note, have you looked at installing the wireshark-dev package from the repository? Yes, it says 1.12.1+g01b65bf-2~ubuntu14.10.3, but that would have gotten you close enough.

(08 May '15, 06:36) Jaap ♦

it is the first time I try compile Wireshark from source code,I really don't want to do it anymore... :P
Basically I googled around, and found out that the source of all issues is goddamn GTK3, so it is needed and recompile Wireshark with GTK2 only (leave qt out).
Well, It is true, with GTK2 all works good.
So, btw, I don't really understand why cursing ourselves with that mess GTK3 (and why there are deb packages for GTK3, QT, but not for GTK2?!?)
Anyway, I did my best trying understand what all those configure options do, and that line you read up is the best I could come out with, so I believe there must be a more correct way, isn't it?.
Yes Jaap, I did that.
Yes, grahamb, let me try to remember myself what I did: I added few -l libs which were required, and which were not added by configure, I used gnu standard make, I dl bison and flex, I cut out from the configure script the part of GDK2 test, because it kept asking for more -lXlibs to add(again maybe there was a smarter way by command line option), then in the resulting makefile, I added 10 or smthg more -lLibs to wireshark link, to dumpcap, and a couple of more tools - and basically that's it.
One very important thing I was forced to discover, with the new gcc, the -l options must all go at end of gcc command line!
Now I really hope someone can decode the meaning of those strace messages I posted, because I already feel cursed.. ;)

(08 May '15, 07:43) nikita

To get a build environment on Debian derivatives you can use apt-get build-dep wireshark.

When I've built on Ubuntu, I've just used the above and then CMake.

(08 May '15, 08:06) grahamb ♦

grahamb, I repeat, the problem is not missing build dependency libs!
.libs/lt-wireshark runs ok.
I already have all libs X, GTK2, and so on, all in (only added bison and flex).

(08 May '15, 08:21) nikita

Which only means that your environment is setup for running Wireshark from its build directory, but not when installed at the system directories. The fact that you apparently need to manually add library references for the linker doesn't bode well here. So what about the raw data? Putting your config.log and strace onto pastbin or alike an option? With just snippets and recollections we're note getting ahead unfortunately. I'm not even sure anyone has a Ubuntu/Utopic platform (or VM) available to work/test with, so the (full) logs will have to do the trick.

(08 May '15, 14:13) Jaap ♦

well Jaap, Im writing here in the hope some Dev from Wireshark team will actually read, and explain what is the meaning of those looped strace messages, e.g. what's that recvmsg 0xbff3ec14, or pool timeout, or anything which can hint where to have a look.
As I said, I'm not gonna recompile anything, that was painful enough, so dunno, what logs can I pastbin foya?
FYI, actually I'm back using the standard pack, as workaround Im saving the load of frames in a pcap under utopic, and then do the analysis under Windows XP where latest Wireshark works as it should (sorry to say, but thats the truth)

(08 May '15, 14:51) nikita
showing 5 of 11 show 6 more comments