This is a static archive of our old Q&A Site. Please post any new questions and answers at

“Failed to connect to Mir: Failed to connect to server socket: No such file or directory” when trying to run Wireshark


i'm trying to run wireshark from another computer and i get this error Failed to connect to Mir: Failed to connect to server socket: No such file or directory

what does that mean and how do i solve it ?

asked 16 Jun '15, 06:58

yas1234's gravatar image

accept rate: 0%

edited 16 Jun '15, 12:06

Guy%20Harris's gravatar image

Guy Harris ♦♦

can you please add a screenshot of Wireshark while it is showing that error.

(16 Jun '15, 09:23) Kurt Knochner ♦

Failed to connect to Mir

Is this on Ubuntu Linux?

(16 Jun '15, 10:45) Guy Harris ♦♦

2 Answers:


Maybe you need to install Wireshark on the machine that you are remoting from? Dunno.

answered 16 Jun '15, 09:06

Irishbug's gravatar image

accept rate: 0%

no i have it

(16 Jun '15, 12:02) yas1234


it"s linux but i solved the problem thanks anyway , it"s bec of wireshark graphical display on the remote computer i had to add a command for it to work !

answered 16 Jun '15, 12:03

yas1234's gravatar image

accept rate: 0%

I asked not just about Linux, but specifically about Ubuntu Linux, because "Mir" is the name of a display server for Linux, being developed for Ubuntu, as a replacement for X11.

The error probably means you're running it on an Ubuntu machine, but not from a GUI session on that machine, and it's therefore failing to connect to the Mir server on that machine. Presumably the command you added was one to try to get it to connect via X11 to the machine on which you had the GUI session.

(16 Jun '15, 12:10) Guy Harris ♦♦

i just added -X to my ssh labpc1 /directory/ and it worked that correct or it's not the best solution ?

(16 Jun '15, 12:21) yas1234

I.e, you did ssh -X labpc1 /directory/

If so, my guess is that the -X flag, by enabling X11 forwarding, causes the DISPLAY environment variable to be set, so that it refers to the machine from which you're doing the ssh, when is run, causing Wireshark to be run with the DISPLAY environment set.

This probably means that the Mir/X11 client libraries that Wireshark uses - or, rather, that GTK+, the GUI toolkit Wireshark is using, uses - will, instead of trying to contact the local Mir server (which fails in the fashion you reported), try to contact the X11 server on the machine from which you did the ssh, so that it opens windows on that machine.

(16 Jun '15, 12:42) Guy Harris ♦♦

I am facing similar same exception on Ubuntu 15.04. My Ubuntu machine is on EC2 Instance(Amazon web services) do not have display/GUI.

Will above solution work in my case also?

(04 Aug '16, 07:49) Prashant