I've been trying to port my dissector to Linux and ran into an issue. The problem is that the only version of lua-devel I can install is 3.0 and higher, which does not compile with Wireshark. It always breaks on the same file, lua_bitop.
I've been trying to install an older version of lua-devel, version 5.2.2. I can't uninstall lua 5.3 because other packages are dependant on it, and I can't install lua 5.2.2 because rpm wants me to have the newest version.
Is there a way I can install both versions? Or is there a better workaround to get lua 5.3 compiling?
asked 16 Jul '15, 12:44
Wireshark can't be compiled with Lua 5.3. Even if the Lua Bitop library was modified to be able to compile/work with Lua 5.3, and whatever else in Wireshark that breaks with Lua 5.3 was fixed, we wouldn't be able to guarantee Lua scripts written by others would work in a Lua 5.3 engine; nor that scripts written on a Lua 5.3-based Wireshark would work in other people's Wireshark programs running Lua 5.2. (the Wireshark binaries shipped for MS-Windows and Mac-OSX are built with Lua 5.2)
If you don't care about compatibility with others, then you could comment out the loading/compiling of the Bitop library (
If you do care about compatibility, then you could download the source code for Lua 5.2 into some directory and build it, then point Wireshark to look in that directory; if you're building with autotools, then during the configure stage you can set the path with the configure option '
Or if you don't care about the Lua stuff at all, you can build wireshark without it.
BTW, what exact operating system are your running, for which there is no RPM of an older Lua version available?
Edit: I should mention there's bug 10881 for this issue as well.
answered 16 Jul '15, 13:49
edited 16 Jul '15, 13:52