This is a static archive of our old Q&A Site. Please post any new questions and answers at

Wireshark Docbook Build Error


I build latest Wireshark master branch by using Nmake and Cmake.

Everything seems fine, I can also create a Visual Studio Solution by using Cmake. However, when I tried to build by using Visual Studio, following errors appears:

Error 1 error : Attempt to load network entity C:\Wireshark_Development\tag\wireshark_tag_branch\build64\docbook\CUSTOMBUILD user_guide_chm

Error 2 error : "xmllint" --nonet --noout --valid "/cygdrive/c/Wireshark_Development/tag/wireshark_tag_branch/build64/docbook/release-notes.xml" returned non-zero exit status 4 C:\Wireshark_Development\tag\wireshark_tag_branch\build64\docbook\a2x release_notes_html

Error 3 error : Attempt to load network entity C:\Wireshark_Development\tag\wireshark_tag_branch\build64\docbook\CUSTOMBUILD developer_guide_chm

I cannot find a way to solve this error, do you help me to understand what is happening?

asked 26 Oct '15, 01:31

BirolCapa's gravatar image

accept rate: 0%


I'm getting the same problem. I've tried manually downloading the docbookx.dtd file into the CUSTOMBUILD directory but that doesn't fix it. I guess because even if I do that cmake still tries the operation during a build.

(03 Nov '15, 23:39) PaulOfford

From memory the catalog.xml file may need some tweaking.

(04 Nov '15, 01:30) Jaap ♦

Are you using MSBuild from the command line or compiling in the VS IDE?

Please try again with MSBuild, redirecting the build output to a text file "2>&1 > build.txt" and post that back here as a comment.

(04 Nov '15, 03:34) grahamb ♦

I'm trying to build with VS IDE. I'll try with MSBuild as you've suggested.

I stepped around the errors associated with the guides with the following:

cmake -D ENABLE_CHM_GUIDES=off -D ENABLE_HTML_GUIDES=off -D ENABLE_PDF_GUIDES=off -G "Visual Studio 12 Win64" ..\

but that still left the xmllint problem. In desparation I broke out procmon. What I found was that xmllint.exe is trying to access a file using a bad file specification:

C:\Development\wireshark\docbook\http \\docbook\xml\4.5\docbookx.dtd

There is a backtick after the string "http". Of course, windows returns PATH NOT FOUND. All issues seem to relate to docbookx.dtd.

(04 Nov '15, 04:33) PaulOfford

Hi Graham,

It was too big to load into comments so I have put it here -

In case it's of any use I've also uploaded the ProcMon output in CSV format -

Best regards...Paul

(04 Nov '15, 05:24) PaulOfford

Does your Cygwin bin directory contain xmllint?

(04 Nov '15, 06:43) grahamb ♦

Yes - c:\cygwin64\bin\xmllint.exe

(04 Nov '15, 08:11) PaulOfford

I'll need to dig into this some more. Might take some time.

(04 Nov '15, 08:29) grahamb ♦

Using msbuild try the following:

msbuild /p:Configuration=RelWithDebInfo .\docbook\release_notes_txt.vcxproj /t:clean
msbuild /p:Configuration=RelWithDebInfo .\docbook\release_notes_txt.vcxproj 2>&1 > build.txt and post the resulting build.txt

This cleans the release_notes project (i.e. docbook\release-notes.html and .txt) and then rebuilds the project.

(04 Nov '15, 09:39) grahamb ♦
(04 Nov '15, 09:55) PaulOfford
showing 5 of 10 show 5 more comments

One Answer:


As per @Jaap's comment above, I think your Cygwin installation is missing the dtd's required for xmllint. My Cygwin has the docbook-xml45 package (under the Text category), can you check if that's installed with Cygwin setup? Installing that package adjusts /etc/xml/catalog.

I also have the docbook-xsl package installed, just in case that's needed as well.

answered 04 Nov '15, 10:20

grahamb's gravatar image

grahamb ♦
accept rate: 22%

Nice one Graham - installing docbook-xml45 has fixed it. Can you or someone move your comment immediately above to the Post Your Answer box?

(04 Nov '15, 14:55) PaulOfford

@grahamb, I was getting the expected 3 build errors for not having those packets. I went ahead and got those added and am still getting one:

"C:\Development\wsbuild32\Wireshark.sln" (default target) (1) -> "C:\Development\wsbuild32\docboo\release_notes_txt.vcxproj.metaproj" (default target) (61) -> (CustomBuild target) -> a2x : error : "lynx" -dump "/cygdrive/c/Development/wsbuild32/docbook/release-notes.text.html" > "/cygdrive/c/Development/wsbuild32/docbook/release-notes.text" returned non-zero exit status 1 [C:\Development\wsbuild32\docbook\release_notes_txt.vcxproj]"

as if I may have missed a dependency somewhere. Any ideas?

(01 Dec '15, 06:05) coloncm

I should add that it builds successfully using the Visual Studio 2013 IDE, and getting the error via command prompt.

(01 Dec '15, 06:26) coloncm

@grahamb,disregard. just needed to refresh my environment settings after changes. Thank you.

(01 Dec '15, 06:36) coloncm