This is a static archive of our old Q&A Site. Please post any new questions and answers at

Usb 3 Support


Will there be usb 3 support?

asked 21 Jul '16, 23:30

Peanut's gravatar image

accept rate: 0%

2 Answers:


answered 21 Jul '16, 23:45

Jaap's gravatar image

Jaap ♦
accept rate: 14%


There is USB3 support, if you have in mind USBPcap on Windows. But the documentation is not really good. In the TODO section of USBPcap's home page, there is a description of the problem and solution. The fact that it prints using stroked-out text suggests that the problem has been solved. There is a link to a mailing list on the topic in the end of that text, but in that list there is still no clear statement how to switch on USB 3.0 support.

So you have to go to the command line, move to the directory where you have told the installer to put USBPcap, and run USBPcapCMD.exe -I . In my case, it looked the following way:

c:\Program Files\USBPcap>USBPcapCMD.exe -I

c:\Program Files\USBPcap>Hardware ID: USB\ROOT_HUB30&VID8086&PID1E31&REV0004 Hardware ID: USB\ROOT_HUB30&VID8086&PID1E31 Hardware ID: USB\ROOT_HUB30 RootHub does not have standard HWID! Added USB\ROOT_HUB30&VID8086&PID1E31&REV0004 to non-standard list. Hardware ID: USB\ROOT_HUB20&VID8086&PID1E26&REV0004 Hardware ID: USB\ROOT_HUB20&VID8086&PID1E26 Hardware ID: USB\ROOT_HUB20 Found standard HWID …

After this, you can start Wireshark again. Either you’ll see one more USBPcapN interface in the list, or the one on which you’ve never captured anything before will “come alive”. Start the capture, insert your USB3.0 device and see the miracle happen.

The theory below is that USB3.0 is in fact a completely separate subsystem with its own root hub and its own electrical contacts on the connectors shared with the USB 1.1/2.0 root hub. So to capture a 3.0 device, you need to capture at a different USBPcapN interface than to capture a 2.0 device inserted to the same connector on your PC.

answered 22 Jul ‘16, 00:26

sindy's gravatar image

accept rate: 24%