This is a static archive of our old Q&A Site. Please post any new questions and answers at

./configure gives error –> GTK+ version issue Solaris

*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error: GTK+ 2.4 or later isn't available, so Wireshark can't be compiled

Please help guys......

asked 03 Aug '11, 03:49

harshpandya88's gravatar image

accept rate: 0%

edited 04 Aug '11, 23:05

helloworld's gravatar image


please help friends......

(03 Aug '11, 05:24) harshpandya88

2 Answers:


Somewhere in the config.log it will tell you why the program did not compile or link. You have to find that section of the file to know the problem.

Since you're Solaris and I'm guessing Solaris 10, you could be running into Sun bug 6213382. The fix for that is to edit the file /usr/lib/pkgconfig/gthread-2.0.pc and:

1) remove "-mt" from the 2 places it appears 2) add "-D_REENTRANT" to Cflags

It may also be that you need to set LD_LIBRARY_PATH (to point to the location of GTK) but since it appears you're using Sun's version of GTK, I'd guess that's not the problem.

answered 03 Aug '11, 06:16

JeffMorriss's gravatar image

JeffMorriss ♦
accept rate: 27%

thx 4 kind help That error has been solved now by above steps but still getting error below

configure:20200: checking pcap.h presence configure:20200: gcc -E -I/usr/local/include conftest.c conftest.c:28:18: pcap.h: No such file or directory configure:20200: $? = 1

configure:20200: checking for pcap.h configure:20200: result: no configure:20207: error: Header file pcap.h not found; if you installed libpcap from source, did you also do "make install-incl", and if you installed a binary package of libpcap, is there also a developer's package of libpcap, and did you also install that package?

(03 Aug '11, 06:31) harshpandya88

Well, where do you have the libpcap header files installed? configure is expecting them in /usr/local/include .

If you don't need to capture you can configure --without-libpcap . If the header file and library are installed somewhere else you can configure --with-pcap=/path/to/where/they/are

(03 Aug '11, 06:40) JeffMorriss ♦

My server doesn't have libpcap installed, i even tried with "--without" option, but still getting the same error again...

I think, i must have to install libcap now..

kindly suggest if any suitable way !!

(03 Aug '11, 06:49) harshpandya88

Doh! Typo: it should be "--without-pcap". Sorry, doing too many things at once.

If that doesn't work, you'll probably have to install libpcap.

(03 Aug '11, 07:17) JeffMorriss ♦

thnx JeffMoriss.. this option worked. and finaly ./configure has completed successfully..

Let me try running make now.. and hopefully it should work.. :)

(03 Aug '11, 07:26) harshpandya88

make: Fatal error: Can't find `makefile': No such file or directory


(03 Aug '11, 07:34) harshpandya88
showing 5 of 6 show 1 more comments


As the error indicates, GTK 2.4 is missing from your machine. You can build it from source.

answered 03 Aug '11, 05:30

bstn's gravatar image

accept rate: 14%

What does config.log show as the error?

(03 Aug '11, 05:59) bstn

from the error it is found that PKG_CONFIG script is pointing to the old copy of GTK version, how i can set modify your LD_LIBRARY_PATH enviroment variable to point it to a newer version already installed in system.

(03 Aug '11, 06:20) harshpandya88