This is a static archive of our old Q&A Site. Please post any new questions and answers at

make command gives error

make: Fatal error: Can't find `makefile': No such file or directory

asked 03 Aug '11, 07:55

harshpandya88's gravatar image

accept rate: 0%

edited 04 Aug '11, 23:06

helloworld's gravatar image


You need to provide a lot more information than this and be much clearer in what it is you're asking.

(03 Aug '11, 08:59) cmaynard ♦♦

Have you run the configure script?

(03 Aug '11, 13:39) Guy Harris ♦♦

I believe he/she has run configure (based on related post).

(03 Aug '11, 15:56) helloworld

OK, so have you solved all the problems in that question yet? Do not try doing "make" until the configure script has run successfully.

(03 Aug '11, 16:05) Guy Harris ♦♦

hi guys.. i have run ./configure command as below. ./configure --without-pcap

after it completes, ifired make and get the error below. make: Fatal error in reader: Makefile, line 3990: Unexpected end of line seen

(03 Aug '11, 22:14) harshpandya88

help me friends...

I have tried GOOGLE, but didn't get help..

(03 Aug '11, 23:25) harshpandya88

What are the contents of the Makefile at that line? (include a few lines before and after to provide context)

(04 Aug '11, 04:15) helloworld

dc_install_base=$(am__cd) $(distdir)/_inst && pwd | sed -e 's,^[^:\\/]:[\\/],/,' && dc_destdir="$${TMPDIR-/tmp}/am-dc-$$$$/" && cd $(distdir)/_build && ../configure --srcdir=.. --prefix="$$dc_install_base" $(DISTCHECK_CONFIGURE_FLAGS) && $(MAKE) $(AM_MAKEFLAGS) && $(MAKE) $(AM_MAKEFLAGS) dvi && $(MAKE) $(AM_MAKEFLAGS) check && $(MAKE) $(AM_MAKEFLAGS) install && $(MAKE) $(AM_MAKEFLAGS) installcheck && $(MAKE) $(AM_MAKEFLAGS) uninstall && $(MAKE) $(AM_MAKEFLAGS)

(04 Aug '11, 04:41) harshpandya88

line 3990 is as per below.

&& $(MAKE) $(AM_MAKEFLAGS) install \

(04 Aug '11, 04:42) harshpandya88

It would probably help to know which version of Wireshark you are trying to compile.

(04 Aug '11, 06:53) cmaynard ♦♦

i am trying to install wireshark-1.4.8 on my Solaris Server.

(04 Aug '11, 22:34) harshpandya88

help me guys..... I am not able to install wire-shark since 2-3 days..

So please help me to come out of this above problem..

(04 Aug '11, 23:06) harshpandya88
showing 5 of 12 show 7 more comments

2 Answers:


The case of 'makefile' is odd to me because configure normally creates Makefile (w/ capital M). Did you perhaps specify the makefile with lower-case (e.g., make -f makefile)? If not, what were your build commands?

After you've run configure, you simply need to type make from the Wireshark source directory to begin building (there's no need to specify the path to Makefile if you're already in the same directory).

answered 03 Aug '11, 16:04

helloworld's gravatar image

accept rate: 28%


FYI, if you're only looking to install Wireshark (and not necessarily from a local build), you can get a standard release from

wireshark-1.6.1-sol10-sparc-local.gz Wireshark (formerly Ethereal) is a network protocol analyzer - installs in /usr/local. If you have installed the gtk+ package and its dependencies, most of the dependencies below should be installed already. You will only need to install adns, libpcap, pcre, gnutls, libgpgerror, libgcrypt, and openssl.


  • openssl-1.0.0d
  • geoip
  • lua
  • pcre
  • libpcap
  • adns
  • gnutls
  • libgpgerror
  • libgcrypt
  • gtk+
  • atk
  • glib
  • pango
  • libiconv
  • xrender
  • cairo
  • render
  • expat
  • fontconfig
  • freetype
  • libpng
  • jpeg
  • tiff
  • zlib
  • renderproto
  • and to have /usr/local/lib/ (either the libgcc-3.4.6 or gcc-3.4.6 packages)

answered 04 Aug '11, 23:39

helloworld's gravatar image

accept rate: 28%

thanks man... I m trying now with above packages install first and then move ahead..

(05 Aug '11, 02:15) harshpandya88