This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Worked great on 10.6 and prior. Upgraded to 10.7, did not work. Uninstalled and reinstalled ver 1.6.1, same ver that was running fine before the upgrade. X11 is not opening in conjunction with Wireshark, but it did in 10.6. See log file. Searched MAC for "_iconv", no hits. Any ideas? Thank you in advance.

Process:         wireshark-bin [470]
Path:            /Applications/Wireshark.app/Contents/Resources/bin/wireshark-bin
Identifier:      wireshark-bin
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  Wireshark [467]

Date/Time:       2011-08-16 22:34:13.941 -0700
OS Version:      Mac OS X 10.7 (11A511)
Report Version:  9

Crashed Thread:  0

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information:
dyld: launch, loading dependent libraries

Dyld Error Message:
  Symbol not found: _iconv
  Referenced from: /usr/lib/libcups.2.dylib
  Expected in: /Applications/Wireshark.app/Contents/Resources/lib/libiconv.2.dylib
 in /usr/lib/libcups.2.dylib

asked 16 Aug '11, 22:49

brianv's gravatar image

brianv
1112
accept rate: 0%

edited 16 Aug '11, 23:22

helloworld's gravatar image

helloworld
3.1k42041


I see this too - X11 doesn't open, so then wireshark doesn't open. If I open X11 first, WS opens, and I can look at an existing pcap - but does not capture properly on en1. I have not yet tested en0. hope this helps -

permanent link

answered 06 Sep '11, 13:50

packetlevel's gravatar image

packetlevel
1667
accept rate: 0%

edited 06 Sep '11, 13:50

I have the same issue, but I can't even get Wireshark to start if X11 is open first....

(07 Oct '11, 06:01) James Dore

What happens if you try to capture on en1?

(07 Oct '11, 13:26) Guy Harris ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×157
×108
×84
×32
×17

question asked: 16 Aug '11, 22:49

question was seen: 6,944 times

last updated: 07 Oct '11, 13:26

p​o​w​e​r​e​d by O​S​Q​A