This is a static archive of our old Q&A Site. Please post any new questions and answers at

Wireshark doesn’t see my interface


Hello all, I've used Wireshark many times in the past in both Windows and Linux. I can spell TCP/IP but I am no expert. On my blazing 750 MHz Linux (2.6.32) Ubuntu (Lucid Lynx 10.04 LTS) machine, Wireshark does not list my NIC card. I expected to see eth0 listed, but it's not. I am on the machine now making this post, so it is active and working. BTW, eth0 is the only NIC card in the machine. Wireshark lists no interfaces. Did I miss a .conf file somewhere? -Shawn

asked 24 Aug '11, 19:37

Shawnerz's gravatar image

accept rate: 0%

edited 26 Aug '11, 14:34

helloworld's gravatar image


2 Answers:


It sounds like you may not have set permissions so that you can capture as a non-root user. Check the CaptureSetup/CapturePrivileges page and /usr/share/doc/wireshark-common/README.Debian.

answered 25 Aug '11, 06:46

multipleinterfaces's gravatar image

accept rate: 12%

Multiple, OK, I wen to Users and Groups in Ubuntu, created a group called 'wireshark' and added myself to the group. Rebooted (Windows habit, sorry) but Wireshark still didn't see the interface.

Then, I went to /user/bin/wireshark and did a sudo ./wireshark, put in my password, and Wireshark saw eth0 and worked great. But on start, WS gave me warning that WS shouldn't be run as root.

Running as root worked but I get the feeling that I'm doing something wrong. Shouldn't I be able to run WS from Ubuntu's Applications | Internet menu? Thanks, -Shawn

(26 Aug '11, 17:51) Shawnerz

Why did you add the "wireshark" group? Did /usr/share/doc/wireshark-common/README.Debian says something about that, or was that from CaptureSetup/CapturePrivileges? If it was from CaptureSetup/CapturePrivileges, note that the "Limiting capture permission to only one group" instructions tell you to do a lot more than just add a "wireshark" group and add yourself to it - read it again and do all of the steps, including the "setcap" step.

(26 Aug '11, 19:19) Guy Harris ♦♦


run this command: sudo apt-get install snmp-mibs-downloader .. and you should be fine

answered 23 Jun '17, 05:24

scofieldzg's gravatar image

accept rate: 0%

edited 23 Jun '17, 05:25

are you sure it belongs here?

(23 Jun '17, 06:36) sindy

For sure, it is written in the captureprivilihes, but also wireshark should run under su

(23 Jun '17, 06:40) scofieldzg

Somehow a combination of

  • an answer which sounds like black magic (why on earth should installation of another package, not related to Wireshark, solve the issue of dumpcap not being run with the right privileges, which is the root cause why the interfaces are not visible)

  • the fact that the question is 6 years old

made me think that you may have been answering a different question actually.

(23 Jun '17, 06:46) sindy

Exactly. That's why I was so confused about your reference to snmp-mibs-downloader.

(23 Jun '17, 07:11) sindy

Isnt that what is mentioned here?

Yes, but it's not mentioned in the context of getting Wireshark to list your interfaces. The manual for a car might talk about both changing the oil and changing the tires, but changing the oil if you have a flat tire probably won't help.

(23 Jun '17, 10:53) Guy Harris ♦♦
showing 5 of 6 show 1 more comments