This is a static archive of our old Q&A Site. Please post any new questions and answers at

Compiling with QtCreator


Topic :) The downloaded source tarball doesn't appear to contain a .pro file. Thank you.

asked 29 Jul '17, 02:38

DigiAngelXX's gravatar image

accept rate: 0%

2 Answers:


Try opening CMakeLists.txt. Qt Creator has supported CMake for some time, and I often use that combination to build on macOS.

answered 29 Jul '17, 08:26

Gerald%20Combs's gravatar image

Gerald Combs ♦♦
accept rate: 24%

Thank you...yes I did get that working...the CMakeLists.txt at least...but the above error is what QtCreator gives me. Ideally I'd like to just use the dev environment that is present in /opt/Qt5.6.1 instead of installing a bunch of system libraries, but I've not had any luck with getting wireshark to see /opt/Qt5.6.1 as the location for libs and headers and what not.

(29 Jul '17, 08:31) DigiAngelXX

You should be able to fix this within Qt Creator by opening the preferences dialog, selecting "Build & Run", then "Qt Versions" and manually adding the 5.6.1 qmake location.

(29 Jul '17, 09:00) Gerald Combs ♦♦


This is because you are not supposed to use QtCreator to compile Wireshark. Follow the development guide instead. Note hat CMake is also supported on Linux (you have a dedicated README in the source tree).

answered 29 Jul '17, 05:21

Pascal%20Quantin's gravatar image

Pascal Quantin
accept rate: 30%

Thanks...I sort of figured it out here:

However the build failed with: :-1: error: No rule to make target '/home/build/wireshark-2.4.0/doc/udpdump.pod', needed by 'doc/udpdump.1'. Stop.

I also tried to tell ./configure that Qt is in /opt/Qt5.6.1, but that failed as well :(

(29 Jul '17, 05:27) DigiAngelXX

This is a bug we fixed after 2.4 release. See

(29 Jul '17, 10:19) Pascal Quantin

Thanks..this worked well with 2.4.2.

(21 Oct '17, 11:08) DigiAngelXX