This is a static archive of our old Q&A Site. Please post any new questions and answers at

Compile error in windows


Hi There,

I tried to compile wireshark on a machine for the first time. I got the below given error.How to resolve this?

copy /B wireshark.pod.template + AUTHORS-SHORT-FORMAT wireshark.pod wireshark.pod.template

AUTHORS-SHORT-FORMAT 1 file(s) copied. copy ..\docbook\ws.css . 1 file(s) copied. bash -o igncr pod2html –title="The Wireshark Network Analyzer 1.6.1" –css=ws.css –noindex wireshark.pod > wireshark.html

Can't execute /usr/bin/pod2html. NMAKE : fatal error U1077: 'bash' : return code '0x1d' Stop.

NMAKE : fatal error U1077: '"C:\Program Files (x86)\Microsoft Visual Studio 9.0
VC\BIN\nmake.exe"' : return code '0x2' Stop.

Please Help.

This question is marked “community wiki”.

asked 22 Nov ‘11, 21:53

Terrestrial%20shark's gravatar image

Terrestrial …
accept rate: 42%

edited 22 Nov ‘11, 23:27

grahamb's gravatar image

grahamb ♦

I read in the microsoft site that when the given command or program called by NMAKE failed then it returns the above given exit code U1077. As they suggested I used /I along with nmake -f Makefile.nmake all /I. It ignored the error and worked well but may I know How does that error completely get resolved?

(22 Nov ‘11, 22:10) Terrestrial …

2 Answers:


I converted your "answer" to a comment.

It looks like your environment is lacking something and is unable to execute the pod2html script as can be seen by the line Can't execute /usr/bin/pod2html.

Check that the script is in the place indicated. If it isn't then you'll need to add a package to your Cygwin install that contains the script, see the Cygwin Packages page to search for one containing the required item.

If you do have the file then something else is wrong an you should see if the script can be executed from a Cygwin prompt, and work from there.

answered 22 Nov '11, 23:34

grahamb's gravatar image

grahamb ♦
accept rate: 22%

pod2html is present inside /usr/bin directory. pod2html is running properly wireshark.pod and wireshark.pod.template. But it dint write anything into wireshark.html. when I execute bash -o igncr pod2html --title="The Wireshark Network Analyzer 1.6.1" --css=ws.css --noindex wireshark.pod > wireshark.html

from cygwin. It errors as "Cant execute /usr/bin/pod2html"

What would be the problem? Please Help.

(25 Nov '11, 01:27) Terrestrial ...


Here is what I did to make it work: Edit the file config.nmake and insert the full path for pod2man and pod2html as follows POD2MAN=$(SH) /usr/bin/pod2man

POD2HTML=$(SH) /usr/bin/pod2html

It should generate the proper man and html files. I think the problem is that the path to pod2man and pod2html is not passed to bash when running under nmake. If you try to run bash manually from the command line, it generates a html file with the appropriate size.

If this is indeed a general problem, can someone submit this fix to the wireshark developers?

answered 14 May '13, 10:49

makeadiff's gravatar image

accept rate: 0%

edited 14 May '13, 10:50

The build system as-is works perfectly for me, I just tested on trunk, and as far as I know also works well for others which leads me to believe that there is something odd in your build environment.

(15 May '13, 05:02) grahamb ♦

Thanks for confirming that its not a general problem, now I'm sure its my build env. bash pod2html .... gives me an error, but bash /usr/bin/pod2html .... compiles fine. Any thoughts on what I'm missing?

(25 May '13, 13:13) makeadiff

Looking at the error it says "can't execute", maybe a permission problem?

I think you may have to hack the makefile in the problem area to print out some diagnostic info.

(25 May '13, 14:50) grahamb ♦