This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Is it possible to upgrade wireshark in Ubuntu? If so, how can a linux-newby do this?

asked 04 Dec '10, 05:09

Boonie's gravatar image

Boonie
16114
accept rate: 0%


I have 1.4.1 running on Ubuntu-based Linux I am not too deep into Linux, but as far as I remember i had like the same issue and got around it by using

 apt-get update
 apt-get upgrade

and after that manually trying "apt-get install wireshark" and mayby one or two other packages.

Hope that helps

permanent link

answered 06 Dec '10, 05:53

Landi's gravatar image

Landi
2.3k51442
accept rate: 28%

I just tried that. The result is a few lines of info and one of them is (translated NL to EN): Wireshark is already the latest version.

But it is not.

(08 Dec '10, 09:29) Boonie

Did you try

apt-get install wireshark

apt-get install wireshark-common

?

I reinstalled my Linux in a VM to quickly look up the way it worked for me... a regular apt-get upgrade would not install the latest wireshark, while the two commands above did - don't ask me why...

(08 Dec '10, 12:34) Landi

I did. And that responds with "you allready have the latest version"

(11 Dec '10, 10:01) Boonie

Damn, I installed a v10 Ubuntu to test - same issue you have. I was able to install 1.4 from another repository though... So if you want to have 1.4 via apt-get update, i suggest you search for another repo where 1.4 is already packaged and add this to your /etc/apt/sources.list

See http://ubuntuguide.org/wiki/Ubuntu:Jaunty#Third_party_repositories

for more details.

(16 Dec '10, 02:38) Landi

That does not look like something a newby understands within an hour or so.

(19 Dec '10, 01:10) Boonie

I would expect that the Ubuntu packet upgrade manager can handle this, even though the packages may be a few releases behind the latest stable build available at www.wireshark.org. If you need the latest version you can always go for compiling it from scratch, but that is probably a little out of scope for a linux-newbie.

permanent link

answered 04 Dec '10, 15:44

Jasper's gravatar image

Jasper ♦♦
23.8k551284
accept rate: 18%

1.2.11 is the auto installed version. I'd like to go to the 1.4.x version. I do not see a package for linux on the wireshark website. Compiling sounds like something for experts.

(05 Dec '10, 07:45) Boonie

Yes, you'll have to wait for Ubuntu to distribute 1.4, but you can work with 1.2.11 just fine. 1.4 has some improvements but you still can get valid results with 1.2. Compiling isn't totally rocket science but if you're new to Linux it may be a bit too confusing.

(05 Dec '10, 07:49) Jasper ♦♦

Your other option is to find a personal/private update that someone has made to suit your Ubuntu release. These are known as PPAs. http://www.ubuntuupdates.org/pm/wireshark lists that there are 1.4.2-2 wireshark PPAs available for Lucid (Ubuntu 10.04) and Maverick (10.10).

As with anything that is not part of the offical distribution you would have to trust that those guys are doing the right thing. That caveat aside, generally open-source evildoers are found out and extracated pretty quickly.

permanent link

answered 08 Dec '10, 17:27

martyvis's gravatar image

martyvis
8911525
accept rate: 7%

That seem a good option for me. I'm going to try this.

(11 Dec '10, 10:12) Boonie

From your link I found this page. http://www.ubuntuupdates.org/ppa/maverickbleed?dist=maverick

It says to use these commands:

sudo add-apt-repository ppa:maverick-bleed/ppa

sudo apt-get update

sudo apt-get install <package name="">

As package name I used wireshark

That did some installing but wireshark is still at 1.2.11

What am I doing wrong?

My Ubuntu is upgraded to 10.10 so I think I'm using the correct version.

(11 Dec '10, 10:27) Boonie

It seems that the lucid-bleed and maverick-bleed teams have deleted those packages from their repositories. Maybe they had issues with them. You may want to contact them to find out.

https://launchpad.net/~maverick-bleed/+archive/ppa/+packages

(20 Dec '10, 15:28) martyvis

Jelmer Vernooij's daily builds PPA has wireshark 1.4.2 (at least right now). The home page is at https://launchpad.net/~jelmer/+archive/daily

Commands:

sudo apt-add-repository ppa:jelmer/daily

sudo apt-get update

sudo apt-get dist-upgrade

permanent link

answered 03 Jan '11, 18:08

puzzlement's gravatar image

puzzlement
11
accept rate: 0%

edited 03 Jan '11, 18:08

I was in touble about wireshark 1.6.5 on ubuntu 10.10 . many errors whiele compiling. too many dependencies and errors installing them. your post did make the difference. thank you very much. The update work and its running now.

(18 Mar '12, 12:22) LuizCar
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×80
×9

question asked: 04 Dec '10, 05:09

question was seen: 41,625 times

last updated: 18 Mar '12, 14:31

p​o​w​e​r​e​d by O​S​Q​A