This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have installed 1.8.2 over a previous installation that worked before I upgraded to ML. I installed XQuartz. I rebooted. I browsed to XQuartz when OSX wanted to know what to use for X11. I ran by clicking Wireshark. This results in XQ being launched, but no WS. I tried launching WS in a terminal and got this set of messages. Is this version just broken?

bobs-rmbp:~ rjc$ wireshark

2012-08-15 16:27:40.747 defaults[2358:707]

The domain/default pair of (kCFPreferencesAnyApplication, AppleAquaColorVariant) does not exist

2012-08-15 16:27:40.756 defaults[2359:707] The domain/default pair of (kCFPreferencesAnyApplication, AppleHighlightColor) does not exist

(process:2348): Gtk-WARNING **: Locale not supported by C library. Using the fallback 'C' locale.

(wireshark-bin:2348): Gtk-WARNING **: Unable to locate theme engine in module_path: "clearlooks", 16:27:41 Err Duplicate protocol name "Coseventcomm Dissector Using GIOP API"! This might be caused by an inappropriate plugin or a development error.

Trace/BPT trap: 5

asked 15 Aug '12, 16:35

Lost's gravatar image

Lost
1111
accept rate: 0%

edited 13 Sep '12, 11:07

Guy%20Harris's gravatar image

Guy Harris ♦♦
17.4k335196

I tried installing WS 1.8.1. It apparently won't even install. The install runs fine and says it's finished, but there is no WS app.

(15 Aug '12, 16:58) Lost

I tried re-installing 1.8.2. Now that install acts like the 1.8.1 problem. What is going on?

(15 Aug '12, 17:01) Lost

I.e., you had an installation (probably pre-1.8) that worked before upgrading to Mountain Lion, upgrade to Mountain Lion, and then upgraded Wireshark to 1.8.2?

(10 Sep '12, 17:35) Guy Harris ♦♦

OK, I'll assume that's what you did. The problem has nothing to do with Mountain Lion and everything to do with the Wireshark OS X installer not clearing out plugins from previous Wireshark installations, which breaks any installation of 1.8.x on top of 1.6.x or earlier. I'll update the title etc. to reflect that.

(13 Sep '12, 11:06) Guy Harris ♦♦

And this means you need to do what natenate19's answer says to do. Open up Terminal and run the commands in question.

(13 Sep '12, 11:29) Guy Harris ♦♦

air:~ nate$ rm -rf /Applications/Wireshark.app/Contents/Resources/lib/wireshark/plugins/coseventcomm.*

air:~ nate$ rm -rf /Applications/Wireshark.app/Contents/Resources/lib/wireshark/plugins/cosnaming.*

air:~ nate$ rm -rf /Applications/Wireshark.app/Contents/Resources/lib/wireshark/plugins/parlay.*

air:~ nate$ rm -rf /Applications/Wireshark.app/Contents/Resources/lib/wireshark/plugins/sercosiii.*

air:~ nate$ rm -rf /Applications/Wireshark.app/Contents/Resources/lib/wireshark/plugins/tango.*

fixt it for me

a 'locate giop' provided no results, and there was no giop plugin...

hm

permanent link

answered 23 Aug '12, 00:00

natenate19's gravatar image

natenate19
311
accept rate: 0%

Ran all those same rm commands from the x11 terminal window and that fixed Wireshark for me, too! Thanks.

(10 Sep '12, 11:22) QuiLoxx

Correct, there is no "GIOP plugin", there were, prior to 1.8, several plugins for GIOP-based protocols, such as the Coseventcomm protocol; those are what you removed.

The problem is that they were made built-in in 1.8, but the 1.8 installer doesn't remove the plugins if they exist, so you end up with two versions of the GIOP-based dissectors. This is bug 7401.

(13 Sep '12, 11:26) Guy Harris ♦♦

Unfortunately Nate's answer does not make any difference in my case. I also tried removing Wireshark.app entirely and reinstalling. I tried 1.8 64 bit, 1.8 32 bit, no difference, total failure every time. I also tried 1.12-rc2, which doesn't even get that far (it fails with some library missing).

(03 Jul '14, 06:40) pkoning

Then your case is probably a different problem, and you need to ask a separate question for it, giving full details (OS version, full Wireshark version (1.8.x, not just 1.8), the results with 1.10.x, and full error information for 1.8.x and 1.10.x).

The 1.12.0rc2 issue is bug 10185.

(03 Jul '14, 07:52) Guy Harris ♦♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×108
×17
×3

question asked: 15 Aug '12, 16:35

question was seen: 12,623 times

last updated: 03 Jul '14, 07:52

p​o​w​e​r​e​d by O​S​Q​A