This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I'm trying to decrypt IEEE 802.11 wireless traffic and am using a NetGear router set to "WPA-PSK [TKIP]" with SSID: rasa and Pass:rasadesign. I'm using Wireshark 1.8.1 (with X11) for Mac and I've tried to enter the string created by Wireshark's PSK generator: 1e3d2784c2693c013d5e20f58371b5b25b92ae00389eaf7c525427dd28b2c3ef but all I get is an error: "error updating record: invalid key format"

I've also tried wpa-pwd with the format "rasa:rasadesign" and "rasadesign:rasa" with the same effect.

I've checked everything I could find on the net about this error, but can't find this problem anywhere. What am I doing wrong? Thanks.

asked 16 Aug '12, 10:29

tabula_rasa's gravatar image

tabula_rasa
1111
accept rate: 0%


As far as wpa-psk is concerned, there was a bug. I checked in a fix in r44694, which will be scheduled to be backported to the 1.8 branch. For now, if you are running Windows, you can test with any automated build version 44694 or later. If the installer isn't there yet, wait a while until the buildbots have finished creating them.

I don't know what the problem is with wpa-pwd.

permanent link

answered 29 Aug '12, 09:22

cmaynard's gravatar image

cmaynard ♦♦
9.4k1038142
accept rate: 20%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×193
×24
×21
×9
×2

question asked: 16 Aug '12, 10:29

question was seen: 7,635 times

last updated: 29 Aug '12, 09:22

p​o​w​e​r​e​d by O​S​Q​A