This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have built wireshark 1.7.0, lua ver lua5.1.dll from win7 OS, 32 bit installer using VS 2008. have set target to win32. After installation when run on a m/c without VS 2008 , it throws an error "unable to start application " with error code 0xc150002 and terminates. It runs properly on a m/c with VS 2008

Please answer 1) can we build an installer on win7 , a 32 bit installer? 2) what should be done resolve error.

Your early inputs will be appreciated

asked 21 Sep '12, 03:13

krithiga's gravatar image

krithiga
31334
accept rate: 0%


1.7.0 is a development version and as such may have issues. I regularly build 32bit wireshark installers on win7 (albeit x64) with no issues. Try a stable version such as 1.8.2.

permanent link

answered 21 Sep '12, 04:01

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

Thanks Grahamb for that quick response. will try with 1.8.2 and will get back in case of issues if any

(21 Sep '12, 04:28) krithiga

I had tried with ver 1.8.2 without my changes. I could run successfully from the 32 bit installer compiled on my win 7 m/c for 32 bit installer. I had set the target platform to win32 explicitly in config.nmake file as below

WIRESHARK_TARGET_PLATFORM=win32

But with my changes, i am unable to run successfully using the generated installer. Getting same error "unable to start application " with error code 0xc150002 ".

I have added logs in ui\gtk\main.c and but it appears that even main() is not being entered.

Any early input will help me lot

(26 Sep '12, 03:28) krithiga

Can you run your modified version from the build directory, i.e. your build dir\wireshark-gtk2? This cuts out the installer part and just runs the newly built copy.

What are your changes, i.e. have you modified an existing dissector, or have you added a new one that maybe has a dependency on another dll that isn't being included in the installer?

(26 Sep '12, 03:59) grahamb ♦

Sonds lika a problem with vcredist or something like that. Can you use VS2010?

(26 Sep '12, 06:46) Anders ♦

Thanks graham for the pointers. Yes i have added a new dissector in plugin directory and it also registers preferences. It is crashing while loading preference of encap type WTAP_ENCAP_USER0. Also have increased the num cols from 7 to 8 in prefs.c file and also added have added new custom columns.

define DEF_NUM_COLS 7-->8

on code review observed that in for loop memory allocation is not as per columns definition.

have updated code and building it. should work now

will get back if there is still issue if any

(26 Sep '12, 07:29) krithiga
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×26

question asked: 21 Sep '12, 03:13

question was seen: 2,496 times

last updated: 26 Sep '12, 07:29

p​o​w​e​r​e​d by O​S​Q​A