This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi! I have a problem that wireshark crashes on startup. After this problem I tried to uninstall it completely and to delete all files regarding wireshark (after "find / | grep -i wireshark") and then reinstall it but that did not help. The first step I guess would be to locate the core dump but I cannot find it - where could it be located?

[[email protected] ~]$ wireshark 
Segmentation fault (core dumped)
[[email protected] ~]$ uname -a
Linux LVALTP0650 3.6.2-4.fc17.x86_64 #1 SMP Wed Oct 17 02:43:21 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
[[email protected] ~]$ wireshark -v
wireshark 1.6.10 (SVN Rev Unknown from unknown)

I am using Fedora 17. Please help me because I cannot work;)

asked 23 Oct '12, 05:18

JacKal's gravatar image

JacKal
0113
accept rate: 0%

some questions:

  • where did you get the binary from? The Fedora repository or some rpm repository on the internet?
  • do you get the same error, if you run wireshark as root (not recommended, just for this test!)?
(23 Oct '12, 05:41) Kurt Knochner ♦
  • sudo yum install wireshark*
  • if I "su -" then wiresharl still core dumps

Before this wireshark worked ok and or a few days I did not use it. Maybe it is important to say that I have used BleachBit to clean my pc - maybe that has left some impact.

(23 Oct '12, 05:52) JacKal

O.K. what is the output of these commands.

  • ldd `which wireshark`
  • strace -f -o wireshark.trc wireshark

Please post the output of the first command and the file wireshark.trc somewhere (maybe pastebin.com) and add the links to your answer.

(23 Oct '12, 05:56) Kurt Knochner ♦
(23 Oct '12, 06:06) JacKal

See Bugzilla Bug #866471

Quote: Try removing abrt-addon-python. Abrt supplies a dissector, that imports a library with the same symbol defined as libsmi has.

Hopefully this works

permanent link

answered 24 Oct '12, 04:02

Andrew3726's gravatar image

Andrew3726
6213
accept rate: 100%

edited 24 Oct '12, 04:05

Thanks - that really worked!

When I was looking where did Wireshark dumped that core I found abrt-harvest-vmcore but did not thought about it more.

(24 Oct '12, 06:22) JacKal

All work fine, now!

(27 Oct '12, 06:41) redscc

I had the same issue, with the latest updates from the repositories.

I went to the wireshark site and downloaded the source tar ball and built it from there.

It's quite simple, extract the contents and run ./configure && make

It goes through everything on your system that is required and will stop and let you know if it needs something that isn't there...just do a yum search and then yum install on those packages.

The build does take a little while, but like I said....it works :) (This could be the last case scenario, if nothing else works).

Edit: Last thing you might need to do, is allow your user to access the dumpcap, try this: https://blog.wireshark.org/2010/02/running-wireshark-as-you/

permanent link

answered 24 Oct '12, 04:15

Spies's gravatar image

Spies
162
accept rate: 0%

edited 24 Oct '12, 04:53

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×32
×22
×8

question asked: 23 Oct '12, 05:18

question was seen: 6,998 times

last updated: 27 Oct '12, 06:41

p​o​w​e​r​e​d by O​S​Q​A