This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I've been fiddling around with wireshark capturing packets from my (WPA2 protected) wlan.

I got it to decrypt traffic when it see the four handshakes from a device, but it if another device authenticates, it wont decrypt traffic from that device.

So it goes like this: I have set up the passphrase in preferences, nic is monitor mode.

  • Start capturing.
  • Restart my iphone's wifi
  • EAPOL packets apear and subsequent traffic from my iphone is decrypted
  • Restart my (other) laptop's wifi
  • EAPOL packets appear but the traffic from this device doesn't get encrypted

If i do this the other way around: stop capturing, restart capturing, restart my laptop's wifi and then my iphone's. It only sees decrypted traffic from my laptop.

How can i fix this?

asked 06 Nov '12, 10:47

tbosman's gravatar image

tbosman
1111
accept rate: 0%

Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×165
×41
×38
×36

question asked: 06 Nov '12, 10:47

question was seen: 1,811 times

last updated: 06 Nov '12, 10:47

p​o​w​e​r​e​d by O​S​Q​A