This is our old Q&A Site. Please post any new questions and answers at

Hello, I am trying to read the data sent from a zigbee enabled smart meter but the packets keep saying "Encrypted Payload"

I have inserted both Trust Center and Network Key under Edit->Preferences->Protocols->ZigBee NWK, but I still get the same message.

Here is the format of the Network and Trust Center keys: xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx:xx

I have the security level set as AES 128 Bit Encryption and 32 bit Interity Protection.

Am I doing something wrong?

Thank you!

asked 04 Jan '11, 14:18

ChooseScreenName's gravatar image

accept rate: 0%

You don't say which OS and which version of Wireshark you're using. One simple possibility is that you don't have a version compiled with libcrypt.

(04 Jan '11, 18:07) beroset

Go back to "Edit->Preferences->Protocols->ZigBee NWK" and edit the network key you entered. For byte order, select "Reverse."

permanent link

answered 24 Nov '14, 07:18

ltello1529's gravatar image

accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 04 Jan '11, 14:18

question was seen: 3,621 times

last updated: 24 Nov '14, 07:18

p​o​w​e​r​e​d by O​S​Q​A