This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

You guys know you missed something in 1.8.4 right?

New install of 1.8.3 a couple days ago, no problem

New install of 1.8.4 (two different laptops) today... "missing msvrc100.dll"

asked 29 Nov '12, 09:47

uncleboarder's gravatar image

uncleboarder
1223
accept rate: 0%

Can you provide a little more detail? Which version(s) of Windows? 32-bit or 64-bit?

(29 Nov '12, 10:11) Gerald Combs ♦♦

Is msvcr100.dll (note the spelling) present in c:\Program Files\Wireshark (or c:\Program Files (x86)\Wireshark if you installed the 32-bit executable on a 64-bit system)? Are you running any AV software that might have quarantined this file?

If I run the 32-bit installer (Wireshark-win32-1.8.4.exe) on a Windows XP 32-bit system here the installer log has the line

 Extract: msvcr100.dll

about a tenth of the way from the top. Msvcr100.dll is present in c:\Program\Files\Wireshark and running Dependency Walker on wireshark.exe shows that msvcr100.dll is loaded successfully from that directory. Finally, running wireshark.exe works as expected.

permanent link

answered 29 Nov '12, 10:35

Gerald%20Combs's gravatar image

Gerald Combs ♦♦
3.3k92258
accept rate: 24%

I installed the 64bit version of 1.8.4... it failed. I installed it again... it failed. I installed the 64bit version of 1.6.12... it worked fine.

I'm not really looking for an answer as 1.6.12 is ok for my needs. But I wanted to let you know what I experienced.

Thanks for a great product!

(29 Nov '12, 11:57) uncleboarder

Can you try installing 1.8.4 again? About a tenth of the way down in the installer log (the last screen of the installer) you should see the following:

Extract: vcredist_x64.exe... 100%
Execute: "C:\Program Files\Wireshark\vcredist_x64.exe" /q /norestart
vcredist_x64 returned 0

After the installation you should also have "Microsoft Visual C++ 2010 x86 Redistributable - 10.0.40219" listed in the Programs and Features control panel.

(29 Nov '12, 12:24) Gerald Combs ♦♦

Installing 1.8.4 after having installed 1.6.12... I no longer have the problem. (all 64 bit versions)

I can only assume the uninstallation of 1.6.12, did not uninstall the .dll. I actually did the install 4 times on two different computers before reverting to 1.6.12.

The laptops are now deployed at a remote location to solve a problem.

(29 Nov '12, 17:51) uncleboarder
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×52

question asked: 29 Nov '12, 09:47

question was seen: 5,308 times

last updated: 29 Nov '12, 17:54

p​o​w​e​r​e​d by O​S​Q​A