This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I want to upgrade my wireshark to support LTE Release 10. Please guide me how to start ?

asked 20 Dec '12, 21:11

Scorp's gravatar image

Scorp
1111
accept rate: 0%


Hi, I think the development version mostly does that. But basically you would have to compare all the dissectors for the LTE protocols with the respective protocol specification and make updates where needed. Regards Anders

permanent link

answered 20 Dec '12, 23:38

Anders's gravatar image

Anders ♦
4.6k952
accept rate: 17%

Thanks for the reply Anders.If I wish to upgrade only the ASN1 from one release to another, I will upgrade the packet-lte-rrc.c and the same for s1ap and x2ap. Will any change be required in packet-mac-lte.c/packet-pdcp-lte.c/packet-rlc-lte.c

(23 Dec '12, 23:02) Scorp

I don't know, but probably. You would have to check.

(23 Dec '12, 23:47) Anders ♦

NAS EPS/RRC/PDCP/RLC/MAC LTE dissectors are already Release 11 compliant in current development version. S1AP and X2AP dissectors are still based on v10.3.0.

permanent link

answered 15 Jan '13, 15:11

Pascal%20Quantin's gravatar image

Pascal Quantin
5.5k1060
accept rate: 30%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×36
×16
×2

question asked: 20 Dec '12, 21:11

question was seen: 3,391 times

last updated: 15 Jan '13, 15:11

p​o​w​e​r​e​d by O​S​Q​A