This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi, I've just build wireshark on SUSE 11.3. There were no problems with compilation and installation, but when I try to run it, there is an error "wireshark: error while loading shared libraries: libwiretap.so.0: cannot open shared object file: No such file or directory". This library is in /usr/local/lib but I don't know what to do to run wireshark. Thanks for your help

asked 16 Jan '11, 14:36

tomeks1972's gravatar image

tomeks1972
1112
accept rate: 0%


Did you tell configure where it would be installed? Check your configure log.

Otherwise try setting LD_LIBRARY_PATH before launching Wireshark.

permanent link

answered 17 Jan '11, 13:01

Jaap's gravatar image

Jaap ♦
11.7k16101
accept rate: 14%

Thank you Jaap I solved my problem. In Suse, there was not a such variable. All I had to do was to create a file 'profile.local' in '/etc' with a line inside 'export LD_LIBRARY_PATH=/usr/local/lib'. After reboot everything works fine. See you and good luck.

permanent link

answered 17 Jan '11, 15:57

tomeks1972's gravatar image

tomeks1972
1112
accept rate: 0%

Run 'ldconfig' command(or similar command), Issue should be solved. I had same issue on Ubuntu 14.04, ldconfig helped!

permanent link

answered 03 Sep '14, 01:57

Sharan's gravatar image

Sharan
11123
accept rate: 0%

edited 03 Sep '14, 01:58

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×58

question asked: 16 Jan '11, 14:36

question was seen: 12,327 times

last updated: 03 Sep '14, 01:58

p​o​w​e​r​e​d by O​S​Q​A