This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have tried for several days to build an OSX app that can run on other systems. I can run both cli and app wireshark on my build machine (mountain lion). But when i try to run the app on another mountain lion machine, there are libraries missing, etc. I've added some of those libs manually, but now i seem to have dependencies on two different versions of libiconv. Are the scripts in SVN supposed to work to build a a stand-alone app on mountain lion? Have I missed some flags that should be set? I've used different combinations of macosx-setup, autogen, configure, osx-app, etc. but to no avail. Has anyone successfully built a ML app from the SVN sources?

asked 23 Apr '13, 22:33

jmfinn9's gravatar image

jmfinn9
26114
accept rate: 0%

edited 25 Apr '13, 09:45


I have solved my problem - it was because I had macports installed on my development machine. Once I removed macports, I was able to easily build the macos app with the supplied make target. Thanks everyone for their input.

permanent link

answered 25 Apr '13, 07:50

jmfinn9's gravatar image

jmfinn9
26114
accept rate: 0%

I have tried for several days to build an OSX app that can run on other systems.

After you ran make, you ran make osx-package, and used the dmg that produced to install Wireshark on the other systems, right?

If not, do so. If you just run make, what you have is a Wireshark binary that you can run from the command line and that will work only on a system that has the same libraries installed; that's useful for testing and debugging (and for those of us who view OS X as "a nice BSD Unix that can run Safari, iTunes, and Quicken" :-)), but it's not a self-contained app bundle, like the ones on the dmg you can download from wireshark.org, so you'll have to manually install all the libraries it requires.

(This has nothing to do with Mountain Lion, BTW; it's true for all OS X releases.)

permanent link

answered 23 Apr '13, 23:01

Guy%20Harris's gravatar image

Guy Harris ♦♦
17.4k335196
accept rate: 19%

Thanks for the quick reply. I have tried building the package, but packagemaker (which is now deprecated by Apple) throws an exception and crashes. I'll revisit that, though. Has anyone run packagemaker in ML? Is it just crashing on my system?

(24 Apr '13, 03:55) jmfinn9

I manually built the package with the package manager, but still had the same error. After further investigation - it seems that some parts of wireshark require version 7.0.0 of libiconv and some parts require version 8.0.0 of libiconv. I have not been able to get around this yet.

Has anyone successfully built the stand-alone osx app from either the current svn or the latest source tarball?

(24 Apr '13, 09:37) jmfinn9
1

@jmfinn9 Your "answer" has been converted to a comment as that's how this site works. Please read the FAQ for more information.

(24 Apr '13, 13:37) grahamb ♦

I've run packagemaker on my 10.8.2 system with Xcode 4.6, build version 4H127, so it definitely works on 10.8.2 with that build of Xcode 4.6, at least. Apple may have broken something in a later Xcode release or in 10.8.3; if so, you might have to find a later version of Auxiliary Tools for Xcode - go to Downloads for Apple Developers (you'll need an ADC account for that), and search for "Auxiliary Tools for Xcode" and see whether a later version helps.

(24 Apr '13, 14:28) Guy Harris ♦♦

Thanks graham for fixing my mistake.

(25 Apr '13, 07:52) jmfinn9
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×110
×108
×53
×2

question asked: 23 Apr '13, 22:33

question was seen: 2,461 times

last updated: 25 Apr '13, 09:45

p​o​w​e​r​e​d by O​S​Q​A