This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I have wireshark capture for VoIP with AMR-WB. My capture does not have SIP transactions. So I have set the RTP preference field to decode the RTP packets with appropriate payload type as AMR-WB, octat aligned. I am able to see decoded packets. However, the protocol field shows it as only AMR. The field type bits are properly decoded though to AMR-WB 12.2 kbits. Again, for SID frametype (value 9), I get illegal Frametype - For future use (9). I am using version 1.8.6

asked 24 Apr '13, 11:31

tecMav's gravatar image

tecMav
11112
accept rate: 0%


the protocol field shows it as only AMR

That's the way it's designed, the protocol is AMR.

for SID frametype (value 9), I get illegal Frametype - For future use (9).

Sounds like a bug could you raise a bug report and include a small sample trace and indicate which packet to look at and how preferences should be set.

permanent link

answered 24 Apr '13, 12:21

Anders's gravatar image

Anders ♦
4.6k952
accept rate: 17%

I have one another capture with SIP packets, where the protocol is detected and shown as AMR-WB (in the protocol field I mean)?

(24 Apr '13, 19:59) tecMav

Ok more info for the bug :-)

(24 Apr '13, 22:58) Anders ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×637
×238
×139

question asked: 24 Apr '13, 11:31

question was seen: 5,399 times

last updated: 24 Apr '13, 22:58

p​o​w​e​r​e​d by O​S​Q​A