This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I compiled Wireshark from source code on my debian 7 a few days ago and installed it. I can't surf internet while Wireshark is running. Even pinging the gateway returns a "Destination unreachable" error. But I don't have this issue on Windows.

I tried to change capture modes and this didn't work either. Any idea how to solve this problem? Thanks in advance.

The following is what wireshark --version returns.

Version 1.10.0 (SVN Rev Unknown from unknown)

Copyright 1998-2013 Gerald Combs [email protected] and contributors. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

Compiled (64-bit) with GTK+ 2.24.10, with Cairo 1.12.2, with Pango 1.34.1, with GLib 2.34.1, with libpcap, with libz 1.2.7, without POSIX capabilities, without libnl, without SMI, without c-ares, without ADNS, without Lua, without Python, without GnuTLS, without Gcrypt, without Kerberos, without GeoIP, without PortAudio, with AirPcap.

Running on Linux 3.2.0-4-amd64, with locale en_US.UTF-8, with libpcap version 1.4.0, with libz 1.2.7, without AirPcap. Intel(R) Core(TM) i7-3630QM CPU @ 2.40GHz

Built using gcc 4.7.2.

Wireshark is Open Source Software released under the GNU General Public License.

Check the man page and http://www.wireshark.org for more information.

asked 23 Jun '13, 09:24

maoxin's gravatar image

maoxin
11112
accept rate: 0%

edited 23 Jun '13, 19:45

cmaynard's gravatar image

cmaynard ♦♦
9.4k1038142


Looks more like a bug report to take over to http://bugs.wireshark.org to me.

Instead of quoting version information you should give more details about what your network setup is like. Are you using a cable ethernet connection or Wifi? What kind of network cards do you use? I guess you're running a wireless connector, in which case capturing will most likely set your card to "receive only" - which will then lead to no connectivity. Windows will not allow you to set monitor mode which may be the reason why you can still use the card with that OS.

permanent link

answered 23 Jun '13, 10:20

Jasper's gravatar image

Jasper ♦♦
23.8k551284
accept rate: 18%

Thank you for your reply.I use wifi.My network cards is "Intel Corporation Centrino Wireless-N 2200".

(23 Jun '13, 16:57) maoxin
1

That's what I thought. You need to use a second card to keep Wireless connectivity on Linux while running monitor mode on the first one, because it will be put into receive-only mode.

(24 Jun '13, 02:55) Jasper ♦♦

well,I still can't surf internet even if I change capture mode to promiscuous mode.Last night,I tried to install a previous version (1.8),this one works pretty well.

(25 Jun '13, 00:59) maoxin

There is no "promiscuouos" mode for wireless NICs, you are either in monitor mode or managed mode where you can have an association to a specific wireless AP. How did you capture in 1.8 if you said it is "working"

(25 Jun '13, 08:05) Landi
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×41
×12

question asked: 23 Jun '13, 09:24

question was seen: 2,379 times

last updated: 25 Jun '13, 08:05

p​o​w​e​r​e​d by O​S​Q​A