This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

After having successfully compiled wireshark on windows, I tried to create a windows installer. I am getting the following error on doing a 'nmake -f Makefile.nmake build wireshark installer'

**File: "C:Userst_sidharth1wswinwiresharkwin32vcredist_x86.exe" -> no files found.

Usage: File [/nonfatal] [/a] ([/r] [/x filespec [...]] filespec [...] | /oname=outfile one_file_only)

Error in script "wireshark.nsi" on line 423 -- aborting creation process

NMAKE : fatal error U1077: '"C:Program Files (x86)NSISmakensis.exe"' : return code '0x1'

Stop.

NMAKE : fatal error U1077: '"C:Program Files (x86)Microsoft Visual Studio 9.0 VCBINnmake.exe"' : return code '0x2'

Stop.**

asked 08 Feb '11, 22:25

sid's gravatar image

sid
45192021
accept rate: 0%

Perhaps you need to install the vcredist.. ref the developers guide.

(08 Feb '11, 22:55) Anders ♦

I have downloaded vcredist_x86.exe from microsoft.com and I have installed it. But while installation it does not ask for a path as to where I want to install that.

So where exactly do I need to install the vcredist_x86.exe? And on installation of this redistributable, what files exactly come up??

(09 Feb '11, 00:40) sid

Hi,

Is it possible to make an installer without installing vcredist? Because, in my case, I'm not admin on my computer so I can't install vcredist.

(09 Feb '11, 00:41) Alwik

I don't think so..redistributable files are necessary for the runtime.

Try downloading the msvcr90.dll from the internet and using it. It might work. But I am not completely sure on it.

What is the harm in trying afterall.

sid

(09 Feb '11, 02:04) sid

If you can't even create the installer, then it likely means that you don't have a copy of vcredist_x86.exe saved in your wireshark library directory. By default, this is C:\wireshark-win32-libs\, but it appears you have a non-standard path.

Reference: Create a Wireshark Installer, section 2.2.13.2.

permanent link

answered 13 Feb '11, 18:07

cmaynard's gravatar image

cmaynard ♦♦
9.4k1038142
accept rate: 20%

edited 14 Feb '11, 13:05

I have solved my problem by installing Visual Studio but not the Express Edition. Now Wireshark is well installed, but when I'm trying to launch it, i got a pop-up telling me that i may reinstall wireshark because it's not correctly configured. Any idea?

permanent link

answered 08 Mar '11, 02:20

Alwik's gravatar image

Alwik
1114
accept rate: 25%

The solution is to install visual C++ SP1

permanent link

answered 23 Mar '11, 06:14

Alwik's gravatar image

Alwik
1114
accept rate: 25%

The solution is to install the visual C++ SP1

permanent link

answered 23 Mar '11, 06:19

Alwik's gravatar image

Alwik
1114
accept rate: 25%

edited 23 Mar '11, 06:20

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×1,620
×26

question asked: 08 Feb '11, 22:25

question was seen: 5,120 times

last updated: 23 Mar '11, 06:20

p​o​w​e​r​e​d by O​S​Q​A