This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.
1
1

I am trying to build Wireshark from source and I followed all the directions in http://www.wireshark.org/docs/wsdg_html_chunked/ChSetupWin32.html. When building, I get the following error:

Microsoft (R) Program Maintenance Utility Version 10.00.40219.01 Copyright (C) Microsoft Corporation. All rights reserved.

    bison  -d -p ascend ascend.y -o ascend.c

/usr/bin/bison: m4 subprocess failed NMAKE : fatal error U1077: 'c:\cygwin64\bin\bison.EXE' : return code '0x1' Stop. NMAKE : fatal error U1077: '"c:\Program Files (x86)\Microsoft Visual Studio 10.0 \VC\Bin\nmake.exe"' : return code '0x2' Stop.

Any ideas on what the issue might be?

asked 12 Aug '13, 09:19

miss_develop's gravatar image

miss_develop
21124
accept rate: 0%

I assume from the path to the Cygwin binaries you are using an x64 version of Cygwin.

While it may work, I'm not aware of anyone successfully using an x64 version of Cygwin to build Wireshark. If problems persist you may want to try a 32 bit version.

(12 Aug '13, 11:03) grahamb ♦

Can you verify that you have m4 installed, e.g. by running m4 --version and which m4 from a Cygwin terminal? It looks like Bison either can't find it or is having trouble running it.

permanent link

answered 12 Aug '13, 09:47

Gerald%20Combs's gravatar image

Gerald Combs ♦♦
3.3k92258
accept rate: 24%

That worked! I installed m4 explicitly on Cygwin and it worked. However, I now get another error:

Microsoft (R) Windows (R) Resource Compiler Version 6.1.7600.16385 Copyright (C) Microsoft Corporation. All rights reserved.

    "C:\Python27\python.exe" tools\rdps.py print.ps ps.c
    rm -f svnversion.h
    perl make-version.pl

NMAKE : fatal error U1077: 'c:\cygwin64\bin\perl.EXE' : return code '0xc0000135'

Stop.

(12 Aug '13, 10:26) miss_develop

If an answer has solved your issue, please accept the answer for the benefit of other users by clicking the checkmark icon next to the answer. Please read the FAQ for more information.

(12 Aug '13, 11:00) grahamb ♦

Got it resolved. It was a dependency that was not installed during the Cygwin install.

(12 Aug '13, 11:11) miss_develop

@miss_develop Can you comment on the dependency missing? I'm having the same issue.

(10 Dec '13, 10:12) tlann
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×193
×1

question asked: 12 Aug '13, 09:19

question was seen: 4,957 times

last updated: 10 Dec '13, 10:12

p​o​w​e​r​e​d by O​S​Q​A