This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi everyone,

I've been using wireshark for a long time and all went perfectly until a week ago I tried to sniff my network traffic and it crashed when I hit the start button. It does not matter what interface I pick, it always crashes when trying to capture packets. It seems like problems came along with the new version (1.10). I do not remember what version I was using before (last time I used wireshark was one year ago or so). I tried falling back to 1.8 but it's even worse, it crashes on startup. Here it's the error reported in the command line:

Gtk:ERROR:/build/buildd/gtk+3.0-3.8.1+git20130422.0ce7854a/./gtk/gtkwidget.c:14133:gtk_widget_unregister_window: assertion failed: (user_data == widget)

[1]+ Aborted (`core' dumped) wireshark

OS: Ubuntu 12.10 x64
Wireshark 1.10.3
libpcap: 1.3.0

Edit: I tried to open a capture file in wireshark to try to isolate the problem. Wireshark also crashes when loading the "main packet analysis window"

Any help will be much appreciated. Thanks in advance.

asked 07 Nov '13, 11:41

fernando98's gravatar image

fernando98
1112
accept rate: 0%

edited 08 Nov '13, 10:59

OS, Wireshark and WinPCap versions please.

(08 Nov '13, 04:11) grahamb ♦

all went perfectly until a week ago

what kind of software did you install during that week? Probably another tool/software that uses GTK+ ??

(08 Nov '13, 04:40) Kurt Knochner ♦

Also, as a first workaround measure you might want to delete all your Wireshark profile files to see if it starts up then. Best would be to backup them to a save location first, so if the profile is the problem it may be possible to determine from the backups what exactly the problem was.

(08 Nov '13, 05:33) Jasper ♦♦

I am sorry if I did not explain myself correctly. I have been using wireshark for half a year or so, then I stopped using it for a year and when I went to use it again (last week) it crashed. The amount of software I have installed ever since is tremendous. I also tried removing ~/.wireshark but did not work.

(08 Nov '13, 10:48) fernando98

Gtk:ERROR:/build/buildd/gtk+3.0-3.8.1+git20130422.0ce7854a/./gtk/gtkwidget.c:14133:gtk_widget_unregister_window: assertion failed: (user_data == widget)

There is a bug with that error message, however it is marked as FIXED.

Can you please try to use a more recent (latest) version of Wireshark?

Regards
Kurt

permanent link

answered 11 Nov '13, 07:32

Kurt%20Knochner's gravatar image

Kurt Knochner ♦
24.8k1039237
accept rate: 15%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×193
×25
×8

question asked: 07 Nov '13, 11:41

question was seen: 2,895 times

last updated: 11 Nov '13, 07:32

p​o​w​e​r​e​d by O​S​Q​A