This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I am trying to remove Wireshark from my computer, but upon uninstalling, I immediately receive an error message "rawshark.exe could not be removed. Is it in use?" I am having difficulty finding a way to end the rawshark.exe process - no rawshark.exe process shown in task manager.

I am running Windows 7. Thanks in advance.

Tom

asked 20 Nov '13, 06:41

tjenks2's gravatar image

tjenks2
11112
accept rate: 0%


rawshark.exe is part of the Wireshark install, but isn't normally started unless requested by the user. As it's a command line utility double clicking it from explorer or running it from the command line with parameters just causes an error response and the program exits.

Have you clicked the Task Manager button "Show processes from all users"? Have you tried rebooting and running the uninstall again? I suppose it's possible that some other process is starting rawshark, but it should still show up in Task Mgr if so.

It's possible that rawshark isn't running but some other app has a "lock" on the file, possibly a virus scanner.

permanent link

answered 20 Nov '13, 07:00

grahamb's gravatar image

grahamb ♦
19.8k330206
accept rate: 22%

I tried the task manager and reboot already, and now looked in the "Show processes from all users", but still no luck. If there were a lock on the file, which is possible (I'm running Norton360), do you have ideas as to how to get it unlocked?

(20 Nov '13, 09:04) tjenks2

did you try to delete rawshark.exe manually?

(20 Nov '13, 09:31) Kurt Knochner ♦

If the file is "locked" then you probably won't be able to delete it. I use a utility Unlocker for occasions such as this.

(20 Nov '13, 09:38) grahamb ♦

I was able to delete rawshark manually, though received the same error message for another associated .exe file. After deleting all the .exe files in the Wireshark directory, I was able to fully uninstall. Thanks for the help, a bit of a workaround, but the end goal was reached.

(21 Nov '13, 13:12) tjenks2

Ran into the same problem when trying to install a Wireshark update on Win7.

But manually downloading the update and then running the Wireshark installer using the "Run as administrator" option worked without the need for any other workarounds.

permanent link

answered 18 Mar '14, 09:20

PolarBear's gravatar image

PolarBear
111
accept rate: 0%

I faced with the same problem. Everything that was needed is to run uninstaller with Admin permissions.

(28 Aug '14, 23:30) Pilgrim

Run the Uninstaller at Admininstrater... it will remove everything

(14 Apr '15, 05:25) Rajan Dave

Go to your Startup menu

type in wireshark

click see more results link

Find the downloaded wireshark folder. It will contain an uninstall folder.

Double click this folder and the windows operating system will get you through the rest.

Go throuh these steps from the start and you will be able to delete all folders and captures pertaining to wireshark.

Done Deal

permanent link

answered 20 Jan '15, 12:21

1424dmitch's gravatar image

1424dmitch
61
accept rate: 0%

Right click uninstall.exe and select "run as Administrator"

(03 Dec '15, 03:58) Vash
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×25
×8
×1

question asked: 20 Nov '13, 06:41

question was seen: 18,658 times

last updated: 22 May '17, 09:17

p​o​w​e​r​e​d by O​S​Q​A