This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hi, I use Wireshark for SIP/RTP debugging and the player under Telephony menu reproduce alas RTP streams very bad. I'm running Wireshark on OSX and tested all the releases, the issue started some month ago but I don't know after what.

Do someone have the same problem and a solution for that?

Thank you very Much

Matteo

asked 26 Nov '13, 05:57

Matteo%20Erba's gravatar image

Matteo Erba
11113
accept rate: 0%

the issue started some month ago but I don't know after what.

we need to figure out if the problem is related to the RTP data or to Wireshark. So, if you listen to the same stream on the telephone, how would you rate the quality there (please for the identical RTP stream!!)?

(26 Nov '13, 06:04) Kurt Knochner ♦

The quality is perfect and I can reproduce the same stream on another computer. I have problems with all g.711 streams

(26 Nov '13, 06:35) Matteo Erba

O.K., so you are saying the quality is only bad, if the stream is played with the internal player in Wireshark, right?

If so, can you please be more specific on the problem? What do you mean by: RTP streams very bad. What exactly is bad?

(26 Nov '13, 06:37) Kurt Knochner ♦

Yes, exactly. I mean that the g.711 stream is a phone call but I can't hear the voice, it is like a robot. It's quite difficult to explayn. The graph is OK, I can hear a noise instead the voice of the call

(26 Nov '13, 06:55) Matteo Erba

but I can't hear the voice, it is like a robot

So, you don't hear anything at all, or the voice sounds like a 'robot voice'?

you get the same effect on different systems running Wireshark? Different OS, different Wireshark version?

(26 Nov '13, 07:08) Kurt Knochner ♦

I can hear a noise, I just can understand the conversation if I know what the people says. Is difficult to explain. Try to imagine the a conversation with sounds like an old 33.6 modem I don't know if is possible here but I can upload a record of the sound I can hear. I had the same issue on another computer and was solved with a reinstallation of the OS

(26 Nov '13, 07:55) Matteo Erba

well, if it is possible to upload the file, please do so at one of the following sites: google drive, dropbox, mega.co.nz (or any other online file hoster). Hint: If you are also able to upload the capture file, that might help a lot for troubleshooting.

(26 Nov '13, 10:21) Kurt Knochner ♦
showing 5 of 8 show 3 more comments

O.K. If I analyze the capture file (with Wireshark 1.11.0 on Windows),

Telephony -> VoIP calls -> Player -> Decode

Then select one direction after the other

check mark [] From .... and press "Play"

I can clearly hear a ring and then somebody whistling (without much distortion).

How did you generate the m4a file?

Regards
Kurt

permanent link

answered 27 Nov '13, 06:29

Kurt%20Knochner's gravatar image

Kurt Knochner ♦
24.8k1039237
accept rate: 15%

edited 27 Nov '13, 06:39

Quicktime on my OSX

(27 Nov '13, 07:41) Matteo Erba

I mean how did you export the RTP data from Wireshark and how did you convert that to a M4A file?

(27 Nov '13, 07:42) Kurt Knochner ♦

No, I played the file from wireshark player and recorded it with the mic. So, what you hear is what my computer plays

(27 Nov '13, 08:02) Matteo Erba

O.K. if what I hear is the real 'content' (somebody whistling), the problem is neither related to Wireshark (tested with 1.11.0) nor to the RTP data. As a result it must be related to your system.

(27 Nov '13, 13:08) Kurt Knochner ♦

Yes, the trace is good, the problem is my system but I'm using it since long time and never had problems. It started some weeks ago. So, nobody has the same problem I have?

(28 Nov '13, 02:29) Matteo Erba

You said:

I had the same issue on another computer and was solved with a reinstallation of the OS

Wireshark uses PortAudio to play the audio stream. So, if it does not work on a certain system, there must be something on your system that interferes with PortAudio or the audio system in general. That would also explain, why it works again after a reinstallation of the OS. Hard to diagnose from outside, sorry ....

What is you OS X version and Wireshark version?

Maybe it's related to a recent update of the OS in combination with a incompatibility of the PortAudio version used by Wireshark.

(28 Nov '13, 04:56) Kurt Knochner ♦

OSX 10.9 and Wireshark 1.10.3. Is there a way to reinstall the library or something like this, I reinstalled wireshark many times with different releases (also deleting manually all the files) but the problem is still present

(29 Nov '13, 05:33) Matteo Erba

I don't think this is related to Wireshark, but to some changes within the OS (or OS configuration) by another piece of software. So, reinstalling Wireshark will not help, whereas reinstalling the OS will help, as that removes the modification.

What you can do: try to find the software on your system that interferes with the audio subsystem, possibly something that also uses PortAudio. If you've found it, try to uninstall that software and see if that changes anything.

(29 Nov '13, 05:39) Kurt Knochner ♦
showing 5 of 8 show 3 more comments
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×238
×24

question asked: 26 Nov '13, 05:57

question was seen: 2,816 times

last updated: 29 Nov '13, 05:39

p​o​w​e​r​e​d by O​S​Q​A