This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

I'm trying to build wireshark 1.8.3 release from source to build a plugin that isn't distributed with it. I'm getting the below error.

The error happens whether I build from the command line or VS2010.

Googling the error brings me this which leads me to believe it isn't able to find the compiler. But I've ran vcvars32.bat and I can execute cl.exe and get confirmation that it sees the compiler.

There is a similar issue here It only says it was a dependency that wasn't installed by Cygwin. I double checked that at least verify_tools is giving the correct output. I'm not sure what to check after that.

The Error

"C:\Python27\python.exe" tools\rdps.py print.ps ps.c NMAKE :fatal error U1077: 'C:\Python27\python.exe' : return code '0xc0000135'

asked 09 Dec '13, 16:52

tlann's gravatar image

tlann
76121419
accept rate: 100%

1

That error code is a pretty generic one that means the application broke in some way. Can you run the command specified just from the prompt?

(10 Dec '13, 01:35) grahamb ♦
1

The same error message has been reported in the following question:

http://ask.wireshark.org/questions/23713/error-building-wireshark-from-source

See the first comment of @miss_develop in the answer of @Gerald Combs and then the 'solution' in the second comment:

Cite: Got it resolved. It was a dependency that was not installed during the Cygwin install.

Unfortunately he/she did not tell which dependency was missing.

Running the command manually, as suggested by @grahamb, will probably reveal the missing dependency.

(10 Dec '13, 07:04) Kurt Knochner ♦

Hey thanks for trying to help out. As I said in my post, "The error happens whether I build from the command line or VS2010."
I also noticed that the problem had been reported previously. I put the link in the post above.
When running the build from the command line, it gives me the terse error message with no other hints.

The output above the error just talks about building a resource for the wiretap lib
rc /r image\reordercap.rc Microsoft (R) Windows (R) Resource Compiler Version 6.1.7600.16385 Copyright (C) Microsoft Corporation. All rights reserved.

After that, it shows the error quoted in my post.

(10 Dec '13, 10:12) tlann
1

Sorry, I did not realize you already posted that question as a link. My fault!

Anyway: I'm not sure what you were running manually, but did you try this command in the directory where print.ps is located?

C:\Python27\python.exe" tools\rdps.py print.ps ps.c

What is the output of that command and what is the content of ps.c afterwards?

(11 Dec '13, 07:12) Kurt Knochner ♦

@Kurt Knochner Ughh I wish I would of thought of running that by itself. That is so obvious.
I ran it and got a pop up window saying it wasn't able to find python27.dll.
So this is do to a path problem. After fixing that and rerunning the build it works. Thank you so much. I have learned a leason from this.

(11 Dec '13, 10:04) tlann

Thanks to @Kurt Knochner for helping me troubleshoot this. After running the line the error was happening on by itself, I ran it and got a pop up window saying "The program can't start because python27.dll is missing from your computer. Try reinstalling the program to fix this problem." After fixing this issue, the build worked correctly.

permanent link

answered 11 Dec '13, 10:09

tlann's gravatar image

tlann
76121419
accept rate: 100%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×254
×110

question asked: 09 Dec '13, 16:52

question was seen: 8,004 times

last updated: 11 Dec '13, 10:09

p​o​w​e​r​e​d by O​S​Q​A