This is our old Q&A Site. Please post any new questions and answers at ask.wireshark.org.

Hello there!

I'm trying to track traffic activity from an Axis p5512-E POE camera after a hard reset to factory default. Normally it should broadcast dhcp request and get an ip, otherwise if no dhcp is found it should revert to default ip configuration. Unfortunately this camera sends arp request but it doesn't get any ip address from dhcp (i've tried two different ones) All i get is this message:

4196 520.124027000 169.254.84.77 224.0.0.251 MDNS 318 Standard query 0x0000 ANY axis-00408cdca1ff.local, "QU" question ANY axis-00408cdca1ff.local, "QU" question ANY AXIS P5512-E - 00408CDCA1FF._http._tcp.local, "QU" question ANY AXIS P5512-E - 00408CDCA1FF._axis-video._tcp.local, "QU" question ANY AXIS P5512-E - 00408CDCA1FF H.264._rtsp._tcp.local, "QU" question

Hints are appreciated;)

Cheers

Alessio

asked 24 Mar '14, 21:18

Alessio's gravatar image

Alessio
1111
accept rate: 0%

The packet above is a multicast DNS. If DHCP is configured the camera will send a DHCP Discovery. Use the filter bootp to check for dhcp packets.

(25 Mar '14, 00:27) Roland

Apparently your camera is sending out MDNS requests to detect some services on the network. The IP address it uses is 169.254.84.77, which is an address from a special range (see: http://packetlife.net/blog/2008/sep/24/169-254-0-0-addresses-explained/ ).

So, apparently your camera is not getting an IP address via DHCP, nor does it fall back to a default IP address in one of the usual ranges (192.168.x.x.).

You can try to access the camera with a browser on that IP address: http://169.254.84.77 . If that works, you can then set the IP address manually. Another option would be to capture the DHCP request (and response) to figure out why DHCP does not work. Maybe the camera is not sending any DHCP requests !?!

BTW: There is also a tool called AXIS IP Utility to identify Axis cameras and their IP address on your network. However that is not necessary in your case, as you already know the address (169.254.84.77).

Regards
Kurt

permanent link

answered 25 Mar '14, 00:34

Kurt%20Knochner's gravatar image

Kurt Knochner ♦
24.8k1039237
accept rate: 15%

edited 26 Mar '14, 08:54

Hello Kurt,

Thank you for your insight! Unfortunately i've tried to browse the camera's configuration page using that IP with no success. I've also used the Axis IP Utility with no result: the camera doesn't even show up locally with it's mac address. Guess i'll have it boxed and sent back as faulty;(

(25 Mar '14, 22:23) Alessio

Not sure about the Axis utility, but for using your browser you should make sure the host machine has a network address configured on the same subnet as the camera is apparently using, e.g. 169.256.0.0/16 or 169.256.84.0/24 as otherwise the NIC in the host will be forwarding packets to the default gateway which is unlikely to know how to route to the camera.

As the link provided by Kurt above seems to be broken, here is another explaining private (or link-local) IP addresses: http://en.wikipedia.org/wiki/Private_network

(26 Mar '14, 03:20) grahamb ♦

As the link provided by Kurt above seems to be broken

that's just the 'dumb' markup language, that does not separate the closing ) after the URL. But maybe that's a Layer 8 problem ;-)

Anyway: I fixed it. The link works now, as I added a blank between the URL and the )

(26 Mar '14, 08:55) Kurt Knochner ♦

but for using your browser you should make sure the host machine has a network address

Oh, well... I thought that's clear, but you are absolutely right!! Maybe the OP did not think about the necessary steps to access the camera :-))

(26 Mar '14, 08:57) Kurt Knochner ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×10
×3

question asked: 24 Mar '14, 21:18

question was seen: 3,679 times

last updated: 26 Mar '14, 08:57

p​o​w​e​r​e​d by O​S​Q​A